[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Updates and p2 Install wizard

On 05/21/2010 02:01 PM, Taylor, Richard wrote:
Is there a simple solution ala:
Define the 1.7.0 feature to require bundle abc-[1.7.0, 1.7.0)
No, that won't fly at all because then I will immediately run into conflicts with other features that need abc-1.7.1.

I really want my feature to behave well. It must not introduce unnecessary conflicts in a complex environment. The best way to ensure this is to rely on the API rules that states that API is kept until the major version changes. See: http://wiki.eclipse.org/Version_Numbering.

Regards,
Thomas Hallgren