[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [mylyn-dev] Running Mylyn Code

Hi Killian,

I did what you said and finished setting up the workspace.
I configured the Target Environment as well.
After that, opened MANIFEST.MF file from org.eclipse.mylyn.context.core and clicked 'Launch an Eclipse application'.

And yes, it worked. And I could debug too. Thanks for your help.
One more question: is it necessary to configure an API baseline?

Ivens

On Fri, Aug 3, 2012 at 12:50 PM, Kilian Matt <kilian.matt@xxxxxxxxx> wrote:
The description was written for indigo, since you're using juno, you
have to use the juno update site, which is usually pre-configured.
Just goto Help->Install New Software
In the following dialog select the "The Eclipse Project Updates "
repository for work with. Then there should be a group for "API Tools
Execution Environment Descriptions" and select the desired Execution
Environment and install it.

Kilian

On Fri, Aug 3, 2012 at 4:59 PM, Ivens <ivensportugal@xxxxxxxxx> wrote:
> Hi Kilian,
>
> I have downloaded Eclipse Juno and I have the latest version of Java (SE 6).
> I tried to follow the step:
>
> To Install additional JRE profiles or if you are unable to obtain a J2SE 1.5
> installation, install Add PDE/API Tools Environment Descriptions from the
> Eclipse project repository that corresponds to your Eclipse environment,
> e.g. http://download.eclipse.org/eclipse.updates/3.7
>
> But I dont know how to do it.
> Can you help me?
>
> Thanks,
> Ivens
>
> On Fri, Aug 3, 2012 at 10:52 AM, Kilian Matt <kilian.matt@xxxxxxxxx> wrote:
>>
>> Hi,
>>
>> did you follow the workspace setup[0] documented in the wiki?
>>
>> Kilian
>>
>> [0] http://wiki.eclipse.org/Mylyn_Contributor_Reference#Setup
>>
>> On Fri, Aug 3, 2012 at 3:15 PM, Ivens <ivensportugal@xxxxxxxxx> wrote:
>> > Hi,
>> >
>> > I am post-graduate student and I am trying to work on an extension to
>> > Mylyn.
>> > This extension is related to the Degree of Interest function and Task
>> > Context.
>> >
>> > I cloned Mylyn code (all sub-projects) using git protocol.
>> > My question is: How can I run, and even debug, Mylyn.
>> > I have tried to run it through org.eclipse.mylyn.context.core
>> > MANIFEST.MF >
>> > Launch and Eclipse Application, but i had no success because there are
>> > errors such as (and more):
>> >
>> > !ENTRY org.eclipse.osgi 2 0 2012-08-03 09:50:16.801
>> >
>> > !MESSAGE One or more bundles are not resolved because the following root
>> > constraints are not resolved:
>> >
>> > !SUBENTRY 1 org.eclipse.osgi 2 0 2012-08-03 09:50:16.801
>> >
>> > !MESSAGE Bundle
>> >
>> > reference:file:/Applications/eclipse/plugins/org.eclipse.ui.views.properties.tabbed_3.5.300.v20120523-1955.jar
>> > was not resolved.
>> >
>> >
>> > What is the correct way of running Mylyn?
>> >
>> > Thank you in advance,
>> > Ivens
>> >
>> > _______________________________________________
>> > mylyn-dev mailing list
>> > mylyn-dev@xxxxxxxxxxx
>> > https://dev.eclipse.org/mailman/listinfo/mylyn-dev
>> >
>> _______________________________________________
>> mylyn-dev mailing list
>> mylyn-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/mylyn-dev
>
>
>
> _______________________________________________
> mylyn-dev mailing list
> mylyn-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/mylyn-dev
>
_______________________________________________
mylyn-dev mailing list
mylyn-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/mylyn-dev