[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] AOSGi is not recognized after installing features

First of all, Happy New Year to all!!!


And Hi Oren!

The new year starts good: I found our problem and fixed it. :-)

The reason was a wrong folder layout of the feature within the zip download. A new fixed version is ready for download:

http://www.eclipse.org/equinox/incubator/aspects/downloads/org.aspectj.osgi_1.0.3a_archive.zip

Sorry again for the long delay. Promise to be more responsive from now on...

Cheers,
-Martin




Oren Mishali wrote:
> Hi Martin,
>
> Have you tried to reproduce the bug? It is quite a limitation since I cannot
> install additional plug-ins...
>
> Oren
>
> -----Original Message-----
> From: equinox-dev-bounces@xxxxxxxxxxx
> [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Martin Lippert
> Sent: Wednesday, October 24, 2007 10:11 AM
> To: Equinox development mailing list
> Subject: RE: [equinox-dev] AOSGi is not recognized after installing features
>
> Hi Oren,
>
> I will try to reproduce this to find the problem. Meanwhile you could
> re-install AOSGi and everything works as expected, right?
>
> -Martin
>
>
>
>> Hi Martin,
>>
>> That's what I did:
>> - Installed Eclipse 3.3.1
>> - Added AJDT (update manager)
>> - Added AOSGi (unzipped last version)
>> - Imported demo.eclipse.tooltip and launched it --> worked as expected
>> - Installed Mylin (or EMF) through update manager, restarted and launched
>> again --> no tooltips...
>>
>> Oren
>>
>>
>> -----Original Message-----
>> From: equinox-dev-bounces@xxxxxxxxxxx
>> [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Martin Lippert
>> Sent: Tuesday, October 23, 2007 4:08 PM
>> To: Equinox development mailing list
>> Subject: RE: [equinox-dev] AOSGi is not recognized after installing
>> features
>>
>> Hi Oren,
>>
>> seems like the AOSGi hook is up and running... How does the test case
>> looks like to reproduce this behavior?
>>
>> -Martin
>>
>>
>>> First, I'm testing it with demo.eclipse.tooltip.
>>> When I launch it with the configuration Tooltip Demo (-verbose), the
>>> console
>>> tells:
>>>
>>> [org.aspectj.osgi] info adding AspectJ hooks ...
>>> [org.aspectj.osgi] info supplementing org.eclipse.jface with
>>> [demo.eclipse.tooltip]
>>> [org.aspectj.osgi] info supplementing org.eclipse.jface.databinding with
>>> [demo.eclipse.tooltip]
>>> [org.aspectj.osgi] info supplementing org.eclipse.jface.text with
>>> [demo.eclipse.tooltip]
>>> [org.aspectj.osgi] info supplementing org.eclipse.swt with
>>> [demo.eclipse.tooltip]
>>> [org.aspectj.osgi] info supplementing org.eclipse.swt.win32.win32.x86
>>> with
>>> [demo.eclipse.tooltip]
>>>
>>> However, no effect is noticed and the AOSGi plug-ins do not show up in
>>> the
>>> installed plug-in list.
>>>
>>> Oren
>>>
>>> -----Original Message-----
>>> From: equinox-dev-bounces@xxxxxxxxxxx
>>> [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Martin Lippert
>>> Sent: Tuesday, October 23, 2007 1:27 PM
>>> To: Equinox development mailing list
>>> Subject: Re: [equinox-dev] AOSGi is not recognized after installing
>>> features
>>>
>>> Hi Oren,
>>>
>>>> First, I would like to let you know that AOSGi is functioning on
>>>> Eclipse
>>>> 3.3.1.
>>> Great to hear!!!
>>>
>>> Regarding your problem: What does the OSGi console short status tells
>>> you?
>>> Are the AOSGi bundles part of that list?
>>>
>>> -Martin
>>>
>>>
>>>> Yet, I'm facing a weird problem:
>>>>
>>>> When I'm adding a feature to Eclipse 3.3.1 (using update manager),
>>>> after
>>>> restarting Eclipse the AOSGi plug-ins are not recognized (they don't
>>>> show
>>>> up
>>>> in the installed plug-ins list and of course AOSGi is not functioning).
>>>> This
>>>> happened to me when I tried to add EMF and also Mylin. I tried the
>>>> -clean
>>>> flag and the problem remains. Moreover, even when restoring the
>>>> previous
>>>> Eclipse state the problem remains. This happens only when the features
>>>> are
>>>> added AFTER AOSGi; when AOSGi is added after the features everything
>>>> works
>>>> fine. any suggestions?
>>>>
>>>>
>>>>
>>>> Thanks,
>>>>
>>>> Oren
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> equinox-dev mailing list
>>>> equinox-dev@xxxxxxxxxxx
>>>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>>>>
>>> _______________________________________________
>>> equinox-dev mailing list
>>> equinox-dev@xxxxxxxxxxx
>>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>>> _______________________________________________
>>> equinox-dev mailing list
>>> equinox-dev@xxxxxxxxxxx
>>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>>>
>>>
>>>
>> _______________________________________________
>> equinox-dev mailing list
>> equinox-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>> _______________________________________________
>> equinox-dev mailing list
>> equinox-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>>
>>
>>
>
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>
>
>