[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [wtp-dev] Plans for moving WPT 3.1 build to be using platform 3.5 i-builds?

David,

      Please don't grab EMF 2.5. EMF just committed
https://bugs.eclipse.org/bugs/show_bug.cgi?id=231430 to 2.5, which will
totally break WTP.  As such, we implore you not to move up to this newer
level of EMF until we have had time to react.  (And, if you remember, it is
not just a simple fix- we need to review a lot of code.)  We will still use
https://bugs.eclipse.org/bugs/show_bug.cgi?id=231430 to track the fix.
(And I just bumped it to critical and P1.)

FWIW,

- Carl Anderson
WTP programmer


                                                                           
             David M                                                       
             Williams/Raleigh/                                             
             IBM@IBMUS                                                  To 
             Sent by:                  wtp-dev@xxxxxxxxxxx                 
             wtp-dev-bounces@e                                          cc 
             clipse.org                                                    
                                                                   Subject 
                                       Re: [wtp-dev] Plans for moving WPT  
             07/30/2008 07:17          3.1 build to be using platform      
             PM                        3.5   i-builds?                     
                                                                           
                                                                           
             Please respond to                                             
                 "General                                                  
               discussion of                                               
              project-wide or                                              
               architectural                                               
                 issues."                                                  
             <wtp-dev@eclipse.                                             
                   org>                                                    
                                                                           
                                                                           





> Can WTP 3.1 build start picking up platform's 3.5 i-builds at this
> point? Platform made several fixes that I am interesting in cross-
> testing with WTP code

Are they fixes that really require to be compiled against the new platform?
That'd be important for everyone to know.
Otherwise of course you can just test to your hearts content :)
unless ... do you know if we "break" due to version ranges anywhere? That
too would be very important to know!

And, I can't help but ask ... now that you've sparked my curiosity ... what
platform bugs could be that interesting or important!? :)


As far as when to move up ... it might be best to discuss at status meeting
first? But I would not object to anyone on the releng team updating.
_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev