[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [wtp-dev] How I could restart Project Explorer in J2EE perspective


Its a known problem...

See:  https://bugs.eclipse.org/bugs/show_bug.cgi?id=146609

Ying




John Lanuti/Raleigh/IBM@IBMUS
Sent by: wtp-dev-bounces@xxxxxxxxxxx

11/03/2006 01:15 PM

Please respond to
"General discussion of project-wide or architectural issues." <wtp-dev@xxxxxxxxxxx>

To
"General discussion of project-wide or architectural issues." <wtp-dev@xxxxxxxxxxx>
cc
Subject
RE: [wtp-dev] How I could restart Project Explorer in J2EE perspective






Yavor,


This sounds like a defect.  The project navigator should update for you on facet and runtime changes.  What version of WTP are you on?  The common navigator was a work in progress throughout Eclipse 3.x and is in better shape now in  WTP 1.5.2.


Thanks,


John Lanuti
Software Engineer, IBM Rational
IBM Software Lab - Research Triangle Park, NC
jlanuti@xxxxxxxxxx
t/l 441-7861



"Boyadzhiev, Yavor Vasilev" <yavor.vasilev.boyadzhiev@xxxxxxx>
Sent by: wtp-dev-bounces@xxxxxxxxxxx

11/03/2006 08:57 AM

Please respond to
"General discussion of project-wide or architectural issues." <wtp-dev@xxxxxxxxxxx>

To
"General discussion of project-wide or architectural issues." <wtp-dev@xxxxxxxxxxx>
cc
Subject
RE: [wtp-dev] How I could restart Project Explorer in J2EE perspective







Just for clarification:

 

I know that WTP uses J2EEContentProvider as a content provider for the deployment descriptor. I suppose that my problem will be solved if I call method J2EEContentProvider.inputChanged, but I don’t know how to get the viewer.
Could you please tell me what is the correct way to refresh the Navigator?

 

Best Regards

Yavor



From: wtp-dev-bounces@xxxxxxxxxxx [mailto:wtp-dev-bounces@xxxxxxxxxxx] On Behalf Of Boyadzhiev, Yavor Vasilev
Sent:
Friday, 3. November 2006 15:11
To:
wtp-dev@xxxxxxxxxxx
Subject:
[wtp-dev] How I could restart Project Explorer in J2EE perspective

Hi,

I should implement migration process (changing facets, runtimes etc) for our projects. When I try to expand the migrated project I note that deployment descriptor was disappears, if I restart “Project Explorer” view (close and opening again) then the deployment descriptor appear.

Could you please tell me how I should solve this problem?

Best Regards
Yavor
_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev