[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [smila-user] Change of Record/Blackboard interface for Attachments
- From: JÃrgen Schumacher <juergen.schumacher@xxxxxxxxxxxxx>
- Date: Mon, 19 Dec 2011 17:31:12 +0100
- Accept-language: de-DE, en-US
- Acceptlanguage: de-DE, en-US
- Delivered-to: email@example.com
- Thread-index: Acy+YW8szoK0CaUEQ4WYMVm9RdBu4gACBl3AAAAv8uA=
- Thread-topic: [smila-user] Change of Record/Blackboard interface for Attachments
> any chance of just deprecating the current byte related methods, so that the interface doesnât
> break now, and just have the impls delegate to the new methods?
> Or would that be too much of an overhead?
I thought of this, but the problem is: currently we have "byte getAttachment(name)", which would be the perfect method name for "Attachment getAttachment(name)", of course, and introducing another name now would look strange in the long run. So I was planning to add a method like "byte getAttachmentsAsBytes(name)" as a shortcut, so that adapting to the change should be quite easy. For the setAttachment() methods nothing needs to be changed anyway, just added.
I can also delay the actual commit of the changes to next year, if that would be easier for you. I'm not finished yet anyway (: