[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Disabling apply now

A few questions:
1. What's involved with this change?  It seems like it could / should be a profile property (profile.dynamic), but I don't know if we're that awesome :-).

2. Would this affect the default behaviour for RCP applications? or will this only affect the Eclipse SDK? (i.e. I generate the simple mail app with p2 support -- will the restart dialog change for that application)?

3. Will this have any affect on the market place client?

cheers,
Ian


On Mon, Jun 7, 2010 at 8:11 AM, Pascal Rapicault <pascal@xxxxxxxxxxxx> wrote:
I understand it is kind of late. However I have seen some old-time eclipse users (which should know better) running into it which is why I was suggesting the change.
Also I'm pretty sure this is a one-liner.


On 2010-06-07, at 9:51 AM, Thomas Watson wrote:

Is there any reason why we think people are starting to hit the "apply now" button any more than they did in the past? As far as I know we have had the "apply now" button since 3.0. Are there more cases now where hitting the "apply now" button causes failure?

To say the least, I am hesitant to put this change post RC4. Especially for an issue that has been around for 6+ years.

Tom



<graycol.gif>Pascal Rapicault ---06/05/2010 09:31:00 AM---In the last few weeks, three bugs came in from people who hit the "apply now" button and were disappointed to see that Eclipse

<ecblank.gif>
From:
<ecblank.gif>

Pascal Rapicault <pascal@xxxxxxxxxxxx>
<ecblank.gif>
To:
<ecblank.gif>

P2 developer discussions <p2-dev@xxxxxxxxxxx>
<ecblank.gif>
Date:
<ecblank.gif>

06/05/2010 09:31 AM
<ecblank.gif>
Subject:
<ecblank.gif>

[p2-dev] Disabling apply now





In the last few weeks, three bugs came in from people who hit the "apply now" button and were disappointed to see that Eclipse started throwing a bunch of exceptions.
Of course, not realizing what was the root cause of this (Eclipse is not dynamic), ppl are blaming p2....

Given that the only plugin that can be installed dynamically is the releng plugins (at least that's the only one I know of), I think the default configuration of the SDK should not be offering the "apply now" option in the dialog.

Given that this is a simple change, I would like that we think about this for 3.6, yes I said 3.6 :)

PaScaL_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev




--
R. Ian Bull | EclipseSource Victoria | +1 250 477 7484
http://eclipsesource.com | http://twitter.com/eclipsesource