[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] Backporting p2 to Eclipse 3.4

Hi Pascal,

Thanks for the quick answer. I will start looking into the p2 plugins
and give it a try.
I'll get back if I get any results or get stuck in the process. 
 

Marius Cetateanu 
DevTech  - Software Engineer
Freescale Semiconductor Romania SRL
45, Tudor Vladimirescu Street
Tati Business Center
Bucharest 050881, Romania
www.freescale.com
Phone:    +040 213052078
Mobile:    +040 742191809
Fax:        +040 213052000
email:  Marius.Cetateanu@xxxxxxxxxxxxx



 


________________________________

	From: p2-dev-bounces@xxxxxxxxxxx
[mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Pascal Rapicault
	Sent: Thursday, October 01, 2009 4:46 PM
	To: P2 developer discussions
	Cc: p2-dev@xxxxxxxxxxx; p2-dev-bounces@xxxxxxxxxxx
	Subject: Re: [p2-dev] Backporting p2 to Eclipse 3.4
	
	

	Hi Marius, 
	
	This is not something that we actively support nor that we have
tried.
	However I think it should be doable given that in 3.4 the
dependencies on p2 from the other plug-ins was rather minimal. In fact,
running the API usage tool [1], the only reference I got back was
org.eclipse.pde.p2.ui, which I believe you could simply punt if it
turned out to be incompatible.
	
	However this will not get you the new about dialog behavior
which provides a way for users to uninstall or revert since this relies
on new functionality being introduced in UI plug-in in 3.5. That said
this could probably easily be backported to 3.4 as well as this is
rather self contained.
	
	HTH
	
	PaScaL
	
	[1]
http://download.eclipse.org/eclipse/downloads/drops/S-3.6M2-200909170100
/eclipse-news-M2.html#PDE
	
	Inactive hide details for "Cetateanu Marius-B01107"
---10/01/2009 02:51:35 AM---Hi,"Cetateanu Marius-B01107" ---10/01/2009
02:51:35 AM---Hi,
	
	
	
	From:	 
	"Cetateanu Marius-B01107" <Marius.Cetateanu@xxxxxxxxxxxxx>	
	
	To:	 
	<p2-dev@xxxxxxxxxxx>	
	
	Date:	 
	10/01/2009 02:51 AM	
	
	Subject:	 
	[p2-dev] Backporting p2 to Eclipse 3.4	
________________________________




	
	Hi,
	
	I would like to know if it's possible and feasible to backport
the whole
	p2 updater feature 
	to Eclipse 3.4. We're working on an Eclipse based IDE and we
cannot
	update for the time being 
	to Eclipse 3.5 but we would benefit from having the p2 updater
feature
	from 3.5 in our product.
	If it's possible (we have about 3 weeks to do the backporting)
could
	anyone point me to 
	the documentation I should read to start the process?
	
	Thanks  
	
	Marius Cetateanu  
	DevTech  - Software Engineer
	Freescale Semiconductor Romania SRL 
	45, Tudor Vladimirescu Street 
	Tati Business Center 
	Bucharest 050881, Romania 
	www.freescale.com 
	Phone:    +040 213052078 
	Mobile:    +040 742191809 
	Fax:        +040 213052000 
	email:  Marius.Cetateanu@xxxxxxxxxxxxx
	
	_______________________________________________
	p2-dev mailing list
	p2-dev@xxxxxxxxxxx
	https://dev.eclipse.org/mailman/listinfo/p2-dev