[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] Starting all dependent bundles

You could provide your own customized “config.ini”.  The product configuration editor allows you to specify the config.ini to use.  This is defined within the “Configuration” tab.

 


The contents of this e-mail are intended for the named addressee only. It contains information that may be confidential. Unless you are the named addressee or an authorized designee, you may not copy or use it, or disclose it to anyone else. If you received it in error please notify us immediately and then destroy it.

From: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Leen Toelen
Sent: Wednesday, January 07, 2009 10:43 AM
To: equinox-dev@xxxxxxxxxxx
Subject: [equinox-dev] Starting all dependent bundles

 

Hi,

 

I would like to create a headless product and application meant to be run as a windows service (headless). When creating my product (and product description) I mention all needed plugins. When I export the service, this is my config.ini:

 

osgi.splashPath=platform:/base/plugins/com.my.product.service

eclipse.product=service.Product

osgi.bundles.defaultStartLevel=4

osgi.bundles=org.eclipse.equinox.common@2:start,org.eclipse.update.configurator@3:start,org.eclipse.core.runtime@start

 

When I check the osgi console I see that all my plugins are resolved but not started, and I need to do this manually. How can I make sure that they are started automatically when the product starts?

 

Regards,

Leen Toelen