[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] GWT+Equinox

Ricardo,

I have this working with GWT 1.5 and Eclipse 3.4, so we know it's possible :-).

Have you tried adding javax.servlet to the required plug-ins for GWT? I have a GWT bundle, and I noticed that it depends on javax.servlet. If I remove this dependency I get the class cast exception.

I also removed all the servlet stuff from Exported Packages list. (See the Runtime tab in the Manifest editor).

Cheers,
Ian

Ricardo Giacomin wrote:

Hi there,

I tried to follow the directions from wiki page http://wiki.eclipse.org/index.php/Google_Web_Toolkit_and_Equinox with no success. The problem is that no matter what I do I still get the ClassCastException when the ServletManager tries to instantiate the servlet. It is probably a problem of different servlet API version (2.4 in equinox http and 2.3 in gwt).

I’m using:

GWT 1.5.2

Eclipse 3.4

Jetty Http from http://www.eclipse.org/equinox/server/downloads/jettyhttp-anon.psf

Any hints?

Thank you in advance.

Regards,

Ricardo Giacomin


-- This message has been scanned for viruses and dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is believed to be clean. ------------------------------------------------------------------------

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev


--
R. Ian Bull
PhD Candidate, University of Victoria
http://www.ianbull.com
http://irbull.blogspot.com/


-- This message has been scanned for viruses and dangerous content by MailScanner, and is believed to be clean.