[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Is the P2 installer supposed to work?

Open a bug with the errors you are getting.

Inactive hide details for "Alex Blewitt" ---05/20/2008 07:47:37 PM---I only ask because I downloaded the installer from:   http"Alex Blewitt" ---05/20/2008 07:47:37 PM---I only ask because I downloaded the installer from: http://download.eclipse.org/eclipse/equinox/dr


From:

"Alex Blewitt" <alex.blewitt@xxxxxxxxx>

To:

"Equinox development mailing list" <equinox-dev@xxxxxxxxxxx>

Date:

05/20/2008 07:47 PM

Subject:

[equinox-dev] Is the P2 installer supposed to work?




I only ask because I downloaded the installer from:

 
http://download.eclipse.org/eclipse/equinox/drops/S-3.4RC1-200805161333/index.php#Provisioning

and when running it, it doesn't install the SDK as the documentation suggests:

 
http://wiki.eclipse.org/Equinox_p2_Installer

* Get the installer for your platform from the equinox download page.
* Unzip the installer anywhere on your local disk
* Run the "p2installer" executable
* In the install wizard, select where you want to install the software

Shows a dialog with "Where do you want to install null?"

I had a look at the p2installer.ini:

-showsplash
org.eclipse.platform
-vmargs
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Xms40m
-Xmx256m
-XX:MaxPermSize=256m
-Dorg.eclipse.swt.internal.carbon.smallFonts

No mention of the org.eclipse.equinox.p2.installDescription that the
page suggests it looks for. I try adding it, and get a new message
saying the error is invalid. That's maybe because the URL that that
page points to is invalid:

 
http://update.eclipse.org/eclipse/testUpdates/sdk-installer.properties
- 404 not found

* When finished, you can delete the installer

I deleted it. At least that worked ...

Alex
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev


GIF image

GIF image