[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Loading a bundle based on JRE version

Hallo

I am trying to use the jaxb features in one of my bundles. Since jaxb is part of java1.6 everything runs smoothly in my equinox environment under java 1.6. When using java 1.5 i am using the javax.xml.bind plugin from the eclipse orbit project to provide jaxb functionality. And now there is the problem that this jaxb version from orbit conflicts with the jabx version contained within the jre when running under java 1.6.

What would be the best way to exclude the javax.xml.bind orbit plugin from my equinox runtime when i am running on java1.6 so that i do not run into conflicts here?

Any hints would be much appreciated.

Regards
Moritz Post