[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] [prov] manifest changes

My thought too.  Unfortunately PDE Update Classpath didn't seem to help.

On Feb 21, 2008, at 7:15 PM, Jeff McAffer wrote:

Feels like a missing "Update classpath" or some such. This all works fine
for me though I do have foundation 1.1 installed.


Jeff

-----Original Message-----
From: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-
bounces@xxxxxxxxxxx] On Behalf Of Timothy Webb
Sent: Thursday, February 21, 2008 6:07 PM
To: Equinox development mailing list
Subject: Re: [equinox-dev] [prov] manifest changes

The errors I receive are all due to "is not accessible due to
restriction on required library ....jre..\lib\rt.jar". It appears
that PDE is still attempting to include those values from my JRE. My
guess would be that since I don't have a foundation 1.1 compatible JVM
installed, it is continuing to try and resolve the classes from the
1.6 JRE that I have configured for this workspace instead of using the
org.apache.xerces project that is available. I do indeed see
org.apache.xerces listed in the Plug-in Dependencies for this project.


As a complete guess, I modified by hand the .classpath file.  I moved
the Plug-in Dependencies library prior to the JRE one.  Doing this
fixed the compile errors for me.  I'm guessing we probably shouldn't
be dependent on the ordering of the build path for something like
this...?

On Feb 21, 2008, at 4:44 PM, DJ Houghton wrote:

This is strange... I'm not sure why you would get errors. What type
of
errors do you see? Are they to the effect of "...can't see due to
access
restriction on org.apache.xerces"?

Either way, the code has been checked out for the test build so I
have
reverted the change in HEAD so if you reload you should be ok. But
we still
need to figure out why you are getting these errors.



equinox-dev-bounces@xxxxxxxxxxx wrote on 02/21/2008 04:28:19 PM:

When I picked up this change on two different systems, I receive
build
errors on the artifact repository about not being able to find the
various XML files.  I do have xerces in my workspace and doing the
normal tricks to get the project building seem to be failing.  Any
suggestions on why this change would break compilation?

Thanks,
Tim

On Feb 21, 2008, at 2:47 PM, DJ Houghton wrote:

I have released a change to the manifest file for the
org.eclipse.equinox.p2.artifact.repository project so Kim can test
the
Foundation EE in the build. If you have this project (and this
change)
loaded into your workspace and a Foundation 1.1 VM set up, it will
also
require that you have a project like Xerces also in your workspace.
Xerces
is already in the project set file so you should be good, but I
just
wanted
to give you a heads up in case you see strange errors about not
finding XML
classes.

_______________________________________________ equinox-dev mailing list equinox-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/equinox-dev

_______________________________________________ equinox-dev mailing list equinox-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/equinox-dev

_______________________________________________ equinox-dev mailing list equinox-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/equinox-dev

_______________________________________________ equinox-dev mailing list equinox-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/equinox-dev