[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ecf-dev] ECF 3.5 top-level features...for target platform usage

Hi Folks,

I've created this bug to track this short-term effort [1].

I've made several changes, and now the top-level (categorized) list of features looks like this:

Eclipse Communication Framework (ECF)
    ECF 3.5 Patch for Eclipse
    ECF Remote Services Target Components <-- NEW
    ECF Target Components for Eclipse
    Source for ECF 3.5 Patch for Eclipse
    Source for ECF Target Components for Eclipse


The new one is the 'ECF Remote Services Target Components'. This is *just* the org.eclipse.ecf.remoteservices.sdk.feature feature. Note that this feature is *included* in the ECF Target Components for Eclipse (formerly the whole ECF SDK)


Install into Eclipse of this new feature works fine, but install into the target platform (i.e. new Software Site), does not work with the 'Include required software' checked...I *think* because of the problem in the PDE target platform loader with versions as mentioned by Markus previously on this thread. What I see when I try to do this (install ECF Remote Services Target Components with 'Include required software' checked) is p2 dependency errors...unfortunately I can't copy/paste them from the dialog, but they look like this (this is the first one...there are others that are 'downstream'):

Cannot satisfy dependency:
    From: ECF OSGi Console Provider <version>
    To: package org.eclipse.ecf.core 0.0.0
<more cannot satisfy dependencies>

I've attached the screenshot to the bug [1].

The upshot is that unless someone has ideas about a fix/workaround for this, I think we're going to have to ask people to uncheck the 'Include required software' button on the Target platform add.

One other (relatively minor) thing...I tried to add the 'Source for ECF Remote Services Target Components' feature to the top-level category above and it doesn't seem to want to appear. The source is generated, and it does appear in the list if the 'Categorize' is removed, but I can't get it to appear in the categorized list as above. If anyone knows why this is not happening, then we can fix it on bug [1].

Scott


[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=338574