[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[ecf-dev] Re: emf and 1.4

Scott Lewis wrote:
> Hi Markus,
> 
> Yesterday I downloaded and installed the JRE 1.4 into my workspace, and
> set things so that the 1.4 vm would be used where dictated by the EE
> (rather than using the 1.6 version to simulate 1.4).  I noticed that
> when I did this several of the discovery.ui projects no longer compiled
> using 1.4.  As I recall, most of the errors were due to problems of
> casting results from EMF.  But in any case, if I set the EE to 1.5
> instead of 1.4 these projects compile just fine.
> 
> So...should I set the ee to 1.5 on these projects and commit, or would
> you rather take a look and see if something else is going on?

Hi Scott,

the projects themselves require BREE 1.4. The problem you're seeing
comes from EMF 2.4 depending on 1.5. If you use an older EMF (e.g. 2.2)
you will be fine with 1.4.

Markus