[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[ecf-dev] Re: emf and 1.4

Hi Markus,

OK. The problem created by using EMF 2.2 (i.e. R2_2_maintenance branch) is that the EMF projects then have errors of the following form:

Description Resource Path Location Type
Plug-ins declaring extensions or extension points must set the singleton directive to true MANIFEST.MF org.eclipse.emf.common/META-INF line 4 Plug-in Problem


I've adjusted our releng project set files to point to EMF 2_2_Maintenance instead of 2.4...but then people will have to hack on the EMF 2_2 to add the singleton directive (or you can turn it off with settings I suppose). If you can do anything about that (the EMF manifest issues) please go ahead.

BTW, have you heard from Jan about tomorrow (or anything)? I believe we need to chat (about the upcoming meeting with Siemens, and the RFC119 work in general).

Thanks,

Scott

Markus Alexander Kuppe wrote:
Scott Lewis wrote:
Hi Markus,

Yesterday I downloaded and installed the JRE 1.4 into my workspace, and
set things so that the 1.4 vm would be used where dictated by the EE
(rather than using the 1.6 version to simulate 1.4).  I noticed that
when I did this several of the discovery.ui projects no longer compiled
using 1.4.  As I recall, most of the errors were due to problems of
casting results from EMF.  But in any case, if I set the EE to 1.5
instead of 1.4 these projects compile just fine.

So...should I set the ee to 1.5 on these projects and commit, or would
you rather take a look and see if something else is going on?

Hi Scott,

the projects themselves require BREE 1.4. The problem you're seeing
comes from EMF 2.4 depending on 1.5. If you use an older EMF (e.g. 2.2)
you will be fine with 1.4.

Markus