[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
RE: [dsdp-tm-dev] Do we still need J2SE 1.4 constraint?
- From: "Oberhuber, Martin" <Martin.Oberhuber@xxxxxxxxxxxxx>
- Date: Wed, 13 Feb 2008 09:50:17 +0100
- Delivered-to: firstname.lastname@example.org
- Thread-index: AchuBc1OAxtSiIbSQ5KKHsQpIC2rcQAF1dOg
- Thread-topic: [dsdp-tm-dev] Do we still need J2SE 1.4 constraint?
we definitely want to remain on J2SE-1.4 for
There is currently no compelling reason to require 1.5 --
this might be
revisited for next year's release.
The warning occurs in a development environment only, and
you that when you write new code and don't have 1.4 it
happen by accident that you write code which would not
Just install an 1.4 JVM somewhere and use Prefernces >
> Execution Environments to let Eclipse know where it
Note that Eclipse just needs the 1.4 class libraries at
time. You can still run or debug RSE with 1.5, 1.6 or
Martin Oberhuber, Senior Member of Technical
Staff, Wind River
Target Management Project
Lead, DSDP PMC Member
I got some warnings after check out TM plugins from
"Build path specifies execution environment J2SE-1.4. There are no
JREs in the workspace strictly compatible with this environment"
is caused by the constraints in all MANIFEST.MF files
history, this limitation was added late 2006.
i am wondering that do we
still have this limitation?
Giving the fact that most java developers
are using jdk5 at least, and jdk7.0 is on the road.
MTS at WindRiver
for STP project