[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [wtp-dev] proposed package naming convention to distinguish 'work in progress' API


Craig,

+1

I think it is very useful to drawn the distinction between code that is truly internal and code that is on course to become API. Using "provisional" instead of "internal" works for me.

Another approach might be to use something like "candidateapi" for candidate APIs, and then change that to "api" when the API is ready.

Jeem - any thoughts?

Arthur Ryman,
Rational Desktop Tools Development

phone: +1-905-413-3077, TL 969-3077
assistant: +1-905-413-2411, TL 969-2411
fax: +1-905-413-4920, TL 969-4920
mobile: +1-416-939-5063, text: 4169395063@xxxxxxx
intranet: http://labweb.torolab.ibm.com/DRY6/



Craig Salter/Toronto/IBM@IBMCA
Sent by: wtp-dev-admin@xxxxxxxxxxx

03/08/2005 01:37 AM

Please respond to
wtp-dev

To
wtp-dev@xxxxxxxxxxx
cc
Subject
[wtp-dev] proposed package naming convention to distinguish 'work in progress' API






Hi,


Currently we use 'internal' package names to indicate that code is not supported API.   I know many of us have code that is 'work in progress' API and though its too soon to expose this as 'fully supported API' its seems useful to be able to distinguish these preliminary API's from the rest of our our 'internal' code.  I'd like to propose that we use 'provisional' in our package names to indicate this sort of work in progress API.  I think this will help our customers get a better feel for what parts of our code we eventually intend to promote as API and what parts we consider to be truly internal.


Any opinions?


thanks

Craig


Craig Salter
Rational Studio XML Web Services
Internal Mail: D3/RY6/8200 /MKM
Phone: (905) 413-3918  TL: 969-3918 FAX: (905) 413-4920
Internet: csalter@xxxxxxxxxx     Notes: Craig Salter/Toronto/IBM@IBMCA