[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] Question regarding launcher icons

the icon "BrandingIron" is kind of picky about the .ico file format.

For comparison, .ico file https://github.com/jsievers/tycho-demo/blob/master/tychodemo.product/icons/alt_launcher.ico 

works for me.

Jan

From: tycho-user-bounces@xxxxxxxxxxx [mailto:tycho-user-bounces@xxxxxxxxxxx] On Behalf Of Markward Schubert
Sent: Mittwoch, 6. Juni 2012 13:30
To: Tycho user list
Subject: Re: [tycho-user] Question regarding launcher icons

Hi folks!

Thanks for the advice so far.
Jan's posting made me investigate this in more detail again and I found out, that I missed to provide some additional information, as the bugzilla issue talks about "eclipse-product" packaging.
I hope, that I am getting something wrong with the configuration and that this is not a bug in tycho-p2-director-plugin.

The tycho version in use is 0.15.0.
We have a project "client-aggregator" at the top of the maven project tree.
A submodule of this is the "repository" project. It's type is "eclipse-repository".
Also below "client-aggregator" are the bundles and features.
My .product files live in the "repository" project. We have three of them with different configuration, one for starting out of eclipse, one for tycho-build and a third for developers to manipulate locally.

application.ide.product
application.product
local.application.product

In my tycho-p2-director-plugin I have the following config:

<configuration>
ÂÂÂÂ <products>
ÂÂÂÂ ÂÂÂÂ <product>
ÂÂÂÂ ÂÂÂÂ ÂÂÂÂ <id>application</id>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <attachId>application</attachId>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <!-- <rootFolder>client</rootFolder> -->
ÂÂÂÂ ÂÂÂÂ </product>
ÂÂÂÂÂ </products>
ÂÂÂÂÂ <includeAllDependencies>true</includeAllDependencies>
</configuration>

What is interesting is, that in my target folder indeed "application" was built and packaged, as specified in the config.
But during the build IÂ get an Error, claiming, that (replaced some path-parts with [..]):

Error - 7 icon(s) not replaced in C:\[...]\p2.brandingIron1445578040298711897\launcher.exe using C:\dev\git\[...]client-aggregator\repository\target\products\application.ide\res\launcher.ico

Please note the application.ide ! 
Also the concatenated icon-path is the one from the application.ide.product, not from the application.product.

I don't know if this plays any role, application.ide is the first .product file in the package explorer, reading from top down.

From reading the documentation I understood, that for an "eclipse-repository" it is legal to have several .product files and configure them in the config part as above controls, which ones are built?

Am I missing something here?

Regards,
Markward





2012/6/1 Sievers, Jan <jan.sievers@xxxxxxx>
IIRC this bug has been fixed in tycho 0.11

https://bugs.eclipse.org/bugs/show_bug.cgi?id=349421

Jan

From: tycho-user-bounces@xxxxxxxxxxx [mailto:tycho-user-bounces@xxxxxxxxxxx] On Behalf Of Davy Meers
Sent: Freitag, 1. Juni 2012 08:58
To: tycho-user@xxxxxxxxxxx
Subject: Re: [tycho-user] Question regarding launcher icons

Hi,

as an alternative for copying using ant you could also use the copy-resources goal of the Maven Resources Plugin.

See https://github.com/mudelta/tycho-demo/commit/cc42dc12a972dab122030b046440f47e0485e321Â; for an example.

Kind regards,
Davy
________________________________________
Date: Thu, 31 May 2012 21:13:14 +0200
From: markward.schubert@xxxxxxxxx
To: tycho-user@xxxxxxxxxxx
Subject: [tycho-user] Question regarding launcher icons

Hi folks!

After stumbling across some older posts in this groups archive, which I could not answer directly to for some reason, I open this topic anew.
I guess the issue with the different interpretation of the relative paths to the laucher-icons, as described by an old post by Brian de Alvis is still valid these days?

Link to the old post: http://software.2206966.n2.nabble.com/How-to-apply-patch-no-launcher-icon-TYCHO-300-td6059641.html#a6065474

Does anybody of you use a similar workaround? If so I would love to have a chance to see your specific part in the pom, because I was trying this out and simply could not succeed. My ant Task kept being executed after the applications were assembled and also the property ${product-id} was never resolved.

This is what I tried:


<plugins>
ÂÂÂ ÂÂÂ ÂÂÂ <plugin>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <artifactId>maven-antrun-plugin</artifactId>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <version>1.7</version>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <executions>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <execution>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <phase>package</phase>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <configuration>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <target>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <echo>Ant execution ...</echo>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <copy todir="${project.build.directory}/products/${product-id}/res">
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <fileset dir="../productfolder/res" />
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </copy>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </target>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </configuration>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <goals>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <goal>run</goal>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </goals>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </execution>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </executions>
ÂÂÂ ÂÂÂ ÂÂÂ </plugin>
ÂÂÂ ÂÂÂ ÂÂÂ <plugin>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <groupId>org.eclipse.tycho</groupId>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <artifactId>tycho-p2-director-plugin</artifactId>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <version>${tycho-version}</version>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <executions>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <execution>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <!--(optional) install the product for all configured os/ws/arch environments
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ using p2 director -->
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <id>materialize-products</id>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <goals>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <goal>materialize-products</goal>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </goals>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </execution>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <execution>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <!-- (optional) create product zips (one per os/ws/arch) -->
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <id>archive-products</id>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <goals>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <goal>archive-products</goal>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </goals>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </execution>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </executions>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <!-- (optional) customize the root folder name of the product zip -->
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <configuration>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <products>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <product>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <id>application</id>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <!-- attachId></attachId> -->
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <!-- <rootFolder>client</rootFolder> -->
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </product>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </products>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <includeAllDependencies>true</includeAllDependencies>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <!-- http://dev.eclipse.org/mhonarc/lists/tycho-user/msg00752.html <products>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ <product> <id>xapplication</id> <rootFolder>application</rootFolder> </product>
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </products> -->
ÂÂÂ ÂÂÂ ÂÂÂ ÂÂÂ </configuration>
ÂÂÂ ÂÂÂ ÂÂÂ </plugin>


Thanks for your help,
Markward


_______________________________________________ tycho-user mailing list tycho-user@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-user