[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] Unresolved dependency after migration from Tycho 12.0 to 14.1

On Wed, Jun 6, 2012 at 9:40 AM, Igor Fedorenko <igor@xxxxxxxxxxxxxx> wrote:
What bundles are expected to provide org.eclipse.ui and
org.eclipse.ui.part packages? (it's not 'org.eclipse.ui' bundle).


That's one of our split packages:

org.eclipse.ui.workbench exports the package via:
 org.eclipse.ui.part;ui.workbench=split;mandatory:="ui.workbench",

org.eclipse.ui exports that package via a require-bundle:
Âorg.eclipse.ui.workbench;bundle-version="[3.103.0,4.0.0)";visibility:=reexport,

org.eclipse.ui.ide exports that package with no attributes:
Âorg.eclipse.ui.part,

PW





--
Paul Webster
Hi floor. Make me a sammich! - GIR