[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] why using a composite repository is not working?

Hard to say for sure, but looks like p2 picks inconsistent set of
bundles. From my experience this happens when the bundles use OSGi
features not supported by p2, things like split packages, or when
bundles are inconsistently versioned, i.e. the same version is used even
though bundles are actually different or when newer version is
considered 'older' according to OSGi version comparison rules.

--
Regards,
Igor

On 12-05-23 6:51 AM, Cristiano Gavião wrote:
I got a Missing Constraint:

[ERROR] Internal error: java.lang.RuntimeException:
org.osgi.framework.BundleException: Bundle
org.eclipse.bpmn2.modeler.core cannot be resolved
[ERROR] Resolution errors:
[ERROR] Bundle org.eclipse.bpmn2.modeler.core - Missing Constraint:
Require-Bundle: org.eclipse.graphiti; bundle-version="[0.7.3,1.0.0)"
[ERROR] Bundle org.eclipse.bpmn2.modeler.core - Missing Constraint:
Require-Bundle: org.eclipse.graphiti.ui; bundle-version="[0.7.3,1.0.0)"
[ERROR] Bundle org.eclipse.bpmn2.modeler.core - Missing Constraint:
Import-Package: org.eclipse.graphiti.ui.features; version="0.0.0"
[ERROR] -> [Help 1]
org.apache.maven.InternalErrorException: Internal error:
java.lang.RuntimeException: org.osgi.framework.BundleException: Bundle
org.eclipse.bpmn2.modeler.core cannot be resolved
Resolution errors:
Bundle org.eclipse.bpmn2.modeler.core - Missing Constraint:
Require-Bundle: org.eclipse.graphiti; bundle-version="[0.7.3,1.0.0)"
Bundle org.eclipse.bpmn2.modeler.core - Missing Constraint:
Require-Bundle: org.eclipse.graphiti.ui; bundle-version="[0.7.3,1.0.0)"
Bundle org.eclipse.bpmn2.modeler.core - Missing Constraint:
Import-Package: org.eclipse.graphiti.ui.features; version="0.0.0"

at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:168)
at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)
at
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)

at
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
at
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)

at
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)


On 22/05/12 21:35, Igor Fedorenko wrote:
Both URls are expected to work. What is exact error message that you get?

--
Regards,
Igor



On 12-05-22 8:11 PM, Cristiano Gavião wrote:
Today I got the source of eclipse bpmn2 editor to try to build it for
Juno.

I've used tycho 0.15.0-SNAPSHOT.

For my surprise, when I've used the composite site of Graphiti (0.9.0 -
http://download.eclipse.org/graphiti/updates/milestones), Tycho could
not find the Graphiti bundles...

But it worked after I have changed the URL for this one:
http://download.eclipse.org/graphiti/updates/milestones/S-0.9.0M7-201205091113



Is this the expected behavior ?

thanks,

Cristiano
_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-user

_______________________________________________ tycho-user mailing list tycho-user@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/tycho-user