[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[sirius-dev] Do not install Sirius 0.9 from the Luna M3 repository

Hi,

A major bug is present in the version of Sirius bundled in Luna M3. It was detected at the last minute by David Williams (thanks David), but our fix arrived too late to be included for the M3 release.

The bug is that installing Sirius 0.9 from the Luna M3 repository appear to work but the resulting Eclipse will refuse to start, hanging on the splash screen (an infinite loop is triggered in the dependency resolution code; see bugs #421801, #421706 and #421765 for the details).

The bug is now fixed in Sirius and the versions available from both our update-site [2] and the Luna staging repo [3] are safe to install. To be precise:
- Sirius versions up to and including 0.9.0.201311130903 (the version in M3) contain the bug;
- Sirius versions starting from 0.9.0.201311151109 are fine.


Note that the bug only appear on Luna; Kepler and earlier releases used a different dependency resolution algorithm which did not trigger the bug.

Apart from Sirius itself, the bug only impacts Ecore Tools 2.0, but this prevented the Modeling package to be published for M3.

We apologize for the inconvenience and will take steps to ensure this kind of issue does not occur in the future.

Regards,
Pierre-Charles David (Sirius co-lead)

[1] http://download.eclipse.org/releases/luna
[2] http://download.eclipse.org/sirius/updates/nightly/0.9
[3] http://download.eclipse.org/releases/staging/