[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [platform-swt-dev] BrowserFunction


I didn't realize that this does not work.  As a workaround you can prefix your call with "parent." or "top.".  I've logged https://bugs.eclipse.org/bugs/show_bug.cgi?id=269285 .

Grant




Christopher Deckers <chrriis@xxxxxxxxx>
Sent by: platform-swt-dev-bounces@xxxxxxxxxxx

03/18/09 12:17 PM

Please respond to
"Eclipse Platform SWT component developers list."        <platform-swt-dev@xxxxxxxxxxx>

To
"Eclipse Platform SWT component developers list." <platform-swt-dev@xxxxxxxxxxx>
cc
Subject
Re: [platform-swt-dev] BrowserFunction





Hi Grant,

I copied the generated HTML from Snippet 307 to a file, and loaded
that file in a frame: the function fails (even when I register the
function after a "browser.setUrl("about:blank");"). I tried prefixing
with "window." and "window.document" but it does not work.
What is the proper way to call the Java registered function from
anywhere in an HTML page (not necessarily the top frame)?

If for some reasons it cannot be done currently, then I can file a bug
with my sample code.

Cheers,
-Christopher


On Wed, Mar 18, 2009 at 2:54 PM, Grant Gayed <Grant_Gayed@xxxxxxxxxx> wrote:
>
> Hi Christopher,
>
> What you describe doesn't sound too different from Snippet307, it should
> work.  Please log a report with SWT that shows your case.
>
> Thanks,
> Grant
>
>
>
>
> Christopher Deckers <chrriis@xxxxxxxxx>
> Sent by: platform-swt-dev-bounces@xxxxxxxxxxx
>
> 03/17/09 05:27 PM
>
> Please respond to
> "Eclipse Platform SWT component developers list."
>  <platform-swt-dev@xxxxxxxxxxx>
> To
> "Eclipse Platform SWT component developers list."
> <platform-swt-dev@xxxxxxxxxxx>
> cc
> Subject
> [platform-swt-dev] BrowserFunction
>
>
>
>
> Hi all,
>
> I am investigating the capabilities of the BrowserFunction using 3.5
> M6. I looked at Snippet 307 as a reference.
>
> Basically, I want to register some functions when I create the Browser
> instance, and whenever I navigate on one of my special pages expect
> that any call to my custom functions work. I haven't succeeded so far.
> Is it supported? Should I file a bug/feature request?
> Since I did not manage to install the function permanently, I then
> tried to dispose/install the function at each location changing/change
> event. I did not manage to find the correct combination for this to
> work either... so basically I am stuck at this stage.
>
> Could someone let me know the current status and behavior of this feature?
>
> Cheers,
> -Christopher
> _______________________________________________
> platform-swt-dev mailing list
> platform-swt-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/platform-swt-dev
>
>
> _______________________________________________
> platform-swt-dev mailing list
> platform-swt-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/platform-swt-dev
>
>
_______________________________________________
platform-swt-dev mailing list
platform-swt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/platform-swt-dev