[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [platform-debug-dev] Should cloned views show up in 'Show View' menu?

> -----Original Message-----
> From: platform-debug-dev-bounces@xxxxxxxxxxx 
> [mailto:platform-debug-dev-bounces@xxxxxxxxxxx] On Behalf Of 
> Pawel Piech
> Sent: Monday, April 30, 2012 3:00 PM
> To: platform-debug-dev@xxxxxxxxxxx
> Subject: Re: [platform-debug-dev] Should cloned views show up 
> in 'Show View' menu?
> 
> I noticed it recently as well and assumed it was a fix for 
> accessibility, but I'm not sure.  If you think it's a problem, it's 
> worth raising a bug with UI.

I opened:
https://bugs.eclipse.org/378171

Thanks

> 
> Cheers,
> Pawel
> 
> On 04/30/2012 07:16 AM, Marc Khouzam wrote:
> > Hi,
> >
> > I just noticed that if I clone a debug view (registers, 
> expressions or variables, maybe memory),
> > and then use the 'Window->Show View' menu, there will be 
> multiple entries for the view type,
> > one for each opened view.  So, you can end up with 3 or 4 
> or 10 entries in the menu for
> > "Variables" (for example).
> >
> > Is this intentionally?
> > My knee-jerk reaction was that it was a bug, but I've 
> checked and see this behavior
> > in 3.7 as well.
> >
> > Note that I can see this using 3.8, but not 4.2, as there 
> is a bug in 4.2 that has the entire
> > menu empty currently; but I suspect once that bug is fixed, 
> the same situation will
> > be visible in 4.2 (http://bugs.eclipse.org/378035).
> >
> > Thanks
> >
> > Marc
> > _______________________________________________
> > platform-debug-dev mailing list
> > platform-debug-dev@xxxxxxxxxxx
> > https://dev.eclipse.org/mailman/listinfo/platform-debug-dev
> 
> _______________________________________________
> platform-debug-dev mailing list
> platform-debug-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/platform-debug-dev
>