[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Self-Hosting p2 and PDE SelfHostingProfile

Hi,

I'm playing with the p2 operations API. However, I have some issue when
running/debugging self-hosted using the PDE generated
SelfHostingProfile. I have an application that I'd like to update using
UpdateOperation and where I'd also like to install stuff using
InstallOperation.

I can't get any of the operations working when self-hosting. Both work
fine when I export a product and use them there.

Well, I somehow expected UpdateOperation to not find anything to update
because the root IUs in SelfHostingProfile are just bundles and not
whole features or even product IUs (which I have in the repository).

But when using InstallOperation I get a status indicating that the
installation could not be performed because of a non matching filter.
Funny thing is, that the same IU installs fine when not self-hosting.
The non-matching filter is an os/arch filter which actually should match.

During debugging I tracked the filter down to:
operand: properties ~= $0
parameter:
[(&(|(osgi.arch=x86)(osgi.arch=x86_64))(|(osgi.os=linux)(osgi.os=win32)))]

I'm self-hosting on win32/x86. I have no idea why the filter does not
match. Any tips for further debugging? Do I need to specify/initialize
the environment somewhere? I suspect that the profile is not setup
correctly but I'm not sure.

Thanks in advance!

-Gunnar

-- 
Gunnar Wagenknecht
gunnar@xxxxxxxxxxxxxxx
http://wagenknecht.org/