[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Problem with Eclipse (3.4) P2 Update Manager

Hi John,
Thanks for your reply. I manually updated my content.xml as you suggested but that didn't help. I still get the following error

Unsatisfied dependency: [manas.plugin 1.0.1] requiredCapability: osgi.bundle/org.eclipse.emf/2.4.0
Unsatisfied dependency: [manas.feature.feature.group 1.0.2] requiredCapability: org.eclipse.equinox.p2.iu/manas.plugin/[1.0.1,1.0.1]
Unsatisfied dependency: [manas.plugin 1.0.1] requiredCapability: osgi.bundle/org.eclipse.emf/2.4.0

Is there something else I need to do? Thanks again for your help on this.

Regards,
-Manas


On Mon, Apr 13, 2009 at 10:57 AM, John Arthorne <John_Arthorne@xxxxxxxxxx> wrote:

You can accomplish this by adding a reference in your site that refers to the site containing EMF. Your content.xml file would have something like this:

  <references size='2'>
    <repository url="" href="http://download.eclipse.org/releases/ganymede" target="_blank">http://download.eclipse.org/releases/ganymede' type='0' options='1'/>
    <repository url="" href="http://download.eclipse.org/releases/ganymede" target="_blank">http://download.eclipse.org/releases/ganymede' type='1' options='1'/>
  </references>

This will add the Ganymede repository (both metadata (type='0') and artifacts (type='1')) as references from your repository. Those repositories will then be used when resolving your plugins and dependencies will be installed from those additional sites as required.

John




Manas Dadarkar <manasd@xxxxxxxxx>
Sent by: p2-dev-bounces@xxxxxxxxxxx

04/13/2009 10:32 AM

Please respond to
P2 developer discussions <p2-dev@xxxxxxxxxxx>

To
p2-dev@xxxxxxxxxxx
cc
Subject
[p2-dev] Problem with Eclipse (3.4) P2 Update Manager





Hi,
    I had a question regarding the Eclipse P2 Update Manager. I have a set of plugins that have a dependency on EMF. These plugins need to be deployed on an Eclipse environment provided by a third party. My update site doesn't want to host any EMF plugins since they are hosted on the
eclipse.org site. The third party Eclipse environment doesn't have the Ganymede (3.4) update site registered in its Update Manager so when that Eclipse environment tries to install my plugins, the installation fails with the error that the required dependency on EMF was not satisfied.
    The third party does not want to change their Eclipse environment. Can someone provide me with tips on how I can resolve this issue? Any help would be much appreciated

Thanks in advance.

Regards,

-Manas

_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev