[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Problem with Eclipse (3.4) P2 Update Manager

Hi,
    I had a question regarding the Eclipse P2 Update Manager. I have a set of plugins that have a dependency on EMF. These plugins need to be deployed on an Eclipse environment provided by a third party. My update site doesn't want to host any EMF plugins since they are hosted on the eclipse.org site. The third party Eclipse environment doesn't have the Ganymede (3.4) update site registered in its Update Manager so when that Eclipse environment tries to install my plugins, the installation fails with the error that the required dependency on EMF was not satisfied.
    The third party does not want to change their Eclipse environment. Can someone provide me with tips on how I can resolve this issue? Any help would be much appreciated

Thanks in advance.

Regards,
-Manas