[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Problems mirroring latest Ganymede repository using p2 mirror apps

Hi Folks,
 
3.4.2 is just out and I am trying to bring it in house. As ever this is proving difficult.
 
The Eclipse platform repo apparently mirrored OK. There were errors, so I had to use the -ignoreerrors flag, but I could install all IUs from the mirror into a 3.4.1 install, except one: come.ibm.base.feature.group (reported in email yesterday). However, testing of my Ganymede mirror failed.
 
I started by trying to install all the C and C++ Development IUs. The selection was validated and I pressed the Finish button on the Install dialog. Things progressed for a while then I got this error:
 
An error occurred while collecting items to be installed
  No repository found containing: org.eclipse.datatools.connectivity/osgi.bundle/1.1.2.v200901090028
  No repository found containing: org.eclipse.datatools.connectivity.sqm.core/osgi.bundle/1.0.7.v200902180551
  No repository found containing: org.eclipse.datatools.connectivity.sqm.server.ui/osgi.bundle/1.1.3.v200902120834
  No repository found containing: org.eclipse.datatools.modelbase.sql/osgi.bundle/1.0.1.v200812031125
  No repository found containing: org.eclipse.jpt.core/osgi.bundle/2.0.102.v200901160200
  No repository found containing: org.eclipse.mylyn.ide.ui/osgi.bundle/3.0.5.v20090218-1800-e3x
  No repository found containing: org.eclipse.mylyn.monitor.ui/osgi.bundle/3.0.5.v20090218-1800-e3x
  No repository found containing: org.eclipse.mylyn.resources.ui/osgi.bundle/3.0.5.v20090218-1800-e3x
  No repository found containing: org.eclipse.net4j/osgi.bundle/1.0.8.v200902231136
  No repository found containing: org.eclipse.net4j.jms.api/osgi.bundle/1.0.8.v200902231136
  No repository found containing: org.eclipse.tptp.platform.iac.administrator/osgi.bundle/4.4.201.v200901100100
  No repository found containing: org.eclipse.cdt.core/osgi.bundle/5.0.2.200902130801
  No repository found containing: org.eclipse.cdt.core.win32/osgi.bundle/5.0.0.200902130801
  No repository found containing: org.eclipse.cdt.debug.mi.core/osgi.bundle/5.0.1.200902130801
  No repository found containing: org.eclipse.cdt.managedbuilder.core/osgi.bundle/5.0.2.200902130801
  No repository found containing: org.eclipse.cdt.managedbuilder.ui/osgi.bundle/5.0.2.200902130801
  No repository found containing: org.eclipse.cdt.platform/org.eclipse.update.feature/5.0.2.200902130801
I tried installing the same list of IUs from the external Ganymede site, and was successful. So, somehow, even though there were no errors during the mirroring process, my Ganymede mirror seems broken. I am using the p2 mirror apps from the 3.5M3 release.
 
About 1500 people at my company are currently tapping their feet, waiting for me to make 3.4.2 available internally. I would really appreciate some advice/help.
 
Regards,
 
Miles Daffin
Morgan Stanley | IDEAS Practice Areas
20 Cabot Square | Canary Wharf | Floor 01
London, E14 4QW
Phone: +44 20 7677-5119
Fax: +44 20 7056-4572
Miles.Daffin@xxxxxxxxxxxxxxxxx
 

NOTICE: If received in error, please destroy and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error.