[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Using one agent to install a different product

I didn't specify a version number--the repository containing it only
had one version.  But I got the same error going through the p2 UI
(which is picking the specific version, I imagine).

It didn't matter whether I had a repository containing 3.5 artifacts
available or not, I still got "can't resolve xxx.swt 3.5.0" messages.
In fact I got this message if I removed the Pydev repository, so it
was the inability to satisfy the (open-ended) dependency on Pydev that
caused the swt 3.5.0 message.  My p2 agent is 3.5 M4.

This is with the Pydev 1.4.2 release, so you might be able to recreate it.

--Terry

On Tue, Mar 3, 2009 at 5:05 PM, Ian Bull <irbull@xxxxxxxxxxxxxxxxx> wrote:
> Thanks Terry.  I was pretty sure this should work.
> Do you specify version numbers when you do this?  I wonder if the 3.5 repos
> are getting added in addition to the 3.4.1 repos (I don't think they should
> be), and since 3.5 is > 3.4.1, the 3.5 IUs are getting picked up instead.
> cheers,
> ian
> - Show quoted text -
>
> On Tue, Mar 3, 2009 at 4:57 PM, Terry Parker <tparker@xxxxxxxxxx> wrote:
>>
>> Hi Ian,
>>
>> This is exactly what I have been doing, and it mostly works fine.  The
>> 3.4.x repos don't appear have any metadata problems.
>>
>> There was one persistent error I was getting on an IU I created (via
>> the metadata generator) that refered to PyDev in its feature.xml file.
>>  It complained about not finding a swt 3.5.0 library.  I was able to
>> get rid of this problem by specifying a specific version range for
>> Pydev in my feature.xml.  I have referred to other IUs without
>> specifying version numbers, and I haven't yet tracked down what in the
>> Pydev repository is causing the problem.  But the 3.5.0 errors seem
>> not to be indicative of the actual problem.
>>
>> --Terry Parker
>>
>> On Tue, Mar 3, 2009 at 4:50 PM, Ian Bull <irbull@xxxxxxxxxxxxxxxxx> wrote:
>> > Hi everyone,
>> > I was wondering if this is an acceptable use of the director.
>> > 1. D/L eclipse 3.5 (Say M5)
>> > 2. Create a 3.4.1 repo
>> > Use the director in eclipse 3.5 (./eclipse -application ..director.. )
>> > and
>> > point it to my eclipse 3.4.1 install and install something.
>> > I realize that metadata may not be compatible, but that it not the
>> > problem
>> > I'm experiencing.  Essentially, when I do this, I get a bunch of errors
>> > around IUs with version numbers like 3.5.0 (200902..).  So even though I
>> > pointed it at a 3.4.1 repo (and pointed my p2 data area to a clean dir),
>> > bundles from 3.5 are being found (and provisioned).
>> > Can I use the director in 3.5 (M5) without using the bundles / IUs
>> > there?
>> > Is this a bug, or just a lack of understanding on my part?
>> > cheers,
>> > Ian
>> >
>> > --
>> > R. Ian Bull | EclipseSource Victoria | +1 250 477 7484
>> > http://eclipsesource.com | http://twitter.com/eclipsesource
>> >
>> > _______________________________________________
>> > p2-dev mailing list
>> > p2-dev@xxxxxxxxxxx
>> > https://dev.eclipse.org/mailman/listinfo/p2-dev
>> >
>> >
>> _______________________________________________
>> p2-dev mailing list
>> p2-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/p2-dev
>
>
>
> --
> R. Ian Bull | EclipseSource Victoria | +1 250 477 7484
> http://eclipsesource.com | http://twitter.com/eclipsesource
>
> _______________________________________________
> p2-dev mailing list
> p2-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/p2-dev
>
>