[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Re: Encountered several problems with self-provisioning RCP application

The third issue is not a problem. I just found out that I made a mistake. Sorry for the confusion that it may cause.


The current situation is that the installed p2-maildemo doesn't do automatic update. Meanwhile I am not able to configure it manually, since the Software Update menu won't open (Issue #1). Any clue is highly appreciated!

 

Thanks very much,

Frank




On Wed, Nov 19, 2008 at 10:25 PM, Frank Du <du.qixing@xxxxxxxxx> wrote:
Hey all,

I am exploring self-provisioning RCP application. I followed the steps in Kai's blog, and encountered several problems. Please help to check how I could make it works:
http://toedter.com/blog/?p=27

1. At step 7, when I click Help -> Software Update menu, it says 'Cannot launch the Update UI. This installation has not been configured properly for Software Updates.' It happens when being launched from eclipse. Nothing happens with an exported build. Is there any configuration that I missed? How to configure it?

2. At step 11, I can't do it since Software Update menu does not work.

3. Then I clicked the menu Help -> About RCP Product -> Plug-in Details. In the plug-in list, the RCP is updated to new version 1.0.1. However, its icon is broken. Does it mean that the update is broken?

Thanks so much for the help in advance! Have a nice day!

--
Best Regards,
Frank Du



--
Best Regards,
Frank Du