[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] 3.4.1 incompatibilities?

Update: Exporting from PDE-UI is not working at all (see attached pic).
My steps were:
- Extract Eclipse 3.4.1 (linux/x86/gtk) into a new dir
- Extract the delta pack on top of that 
- Fire up, import my plug-ins
- Build the plug-ins, export the product
- In the wizard, select multiple platforms: linux/x86/gtk,
win32/x86/win32
- Get the attached ping

Not sure what's wrong there but my guess is that since the target
platform only shows plug-ins for the configured target os/ws/arch
combination the plug-ins for other configurations can't be found during
the export operation. If this proves to be reproducable on all hosts and
with all products that's bad :(

So, for now I'll have to revert back to Eclipse 3.4.0, please let me
know if you need a bugzilla to track these issues, I'll have to leave it
at that since my time for looking into this is up already :(

HTH,
Ciao, hh

-----Original Message-----
From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On
Behalf Of Haigermoser, Helmut
Sent: Monday, September 29, 2008 10:35 AM
To: P2 developer discussions
Subject: RE: [p2-dev] 3.4.1 incompatibilities?

Ciao Guys :)
Update: It's not the update process, it's the entire generated
repository. The pde-build-generated content.xml contains unsatisfiable
requirement statements:
    <unit id='toolingwin32.win32.x86org.eclipse.core.net.linux.x86'
version='1.0.0.I20080521' singleton='false'>
      <hostRequirements size='2'>
        <required namespace='osgi.bundle'
name='org.eclipse.core.net.linux.x86' range='1.0.0.I20080521'/>
        <required namespace='org.eclipse.equinox.p2.eclipse.type'
name='bundle' range='[1.0.0,2.0.0)' greedy='false'/>
      </hostRequirements>
      <properties size='1'>
        <property name='org.eclipse.equinox.p2.type.fragment'
value='true'/>
      </properties>
      <provides size='2'>
        <provided namespace='org.eclipse.equinox.p2.iu'
name='toolingwin32.win32.x86org.eclipse.core.net.linux.x86'
version='1.0.0.I20080521'/>
        <provided namespace='org.eclipse.equinox.p2.flavor'
name='toolingwin32.win32.x86' version='1.0.0'/>
      </provides>
      <requires size='2'>
        <required namespace='osgi.bundle'
name='org.eclipse.core.net.linux.x86' range='1.0.0.I20080521'/>
        <required namespace='org.eclipse.equinox.p2.eclipse.type'
name='bundle' range='[1.0.0,2.0.0)' greedy='false'/>
      </requires>
      <filter>
        (&amp; (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))
     </filter>

In this example, how could the IU
'toolingwin32.win32.x86org.eclipse.core.net.linux.x86' with a host
filter of win32,win32,x86 require the bundle
org.eclipse.core.net.linux.x86 which is of course linux,any,x86? The
entire IU makes no sense and a fix will most probably just get rid of
such filter-cross-platform IUs...

This is a show stopper for our usage of 3.4.1, I'm trying to reproduce
things with the UI right now to see whether this is a commandline issue
or not, however, since this used to work for 3.4.0 the faster method to
find a solution here might be to look at all bugfixes trying to find the
culprit in p2/pde (since I have not heard of anybody else having this
problem this might still be my mess-up so please bear with me if it is,
but I don't see how right now)

So far, so bad :(
Helmut

-----Original Message-----
From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On
Behalf Of Haigermoser, Helmut
Sent: Thursday, September 25, 2008 3:51 PM
To: P2 developer discussions
Subject: RE: [p2-dev] 3.4.1 incompatibilities?

Hei Pascal :)
That's done pde build while exporting the product. The build is
configured to build for three different configs:
win32,win32,x86
solaris,gtk,sparc
linux,gtk,x86
HTH,
Ciao, hh 

-----Original Message-----
From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On
Behalf Of Pascal Rapicault
Sent: Thursday, September 25, 2008 3:09 PM
To: P2 developer discussions
Cc: P2 developer discussions; p2-dev-bounces@xxxxxxxxxxx
Subject: Re: [p2-dev] 3.4.1 incompatibilities?

Are you generating the metadata for 3.4.1 yourself?

Inactive hide details for "Haigermoser, Helmut" ---25/09/2008 08:06:31
AM---Ciao Guys :) I need your help once more, thanks a l"Haigermoser,
Helmut" ---25/09/2008 08:06:31 AM---Ciao Guys :) I need your help once
more, thanks a lot for anything you can give me to



From:	
"Haigermoser, Helmut" <Helmut.Haigermoser@xxxxxxxxxxxxx>	

To:	
"P2 developer discussions" <p2-dev@xxxxxxxxxxx>	

Date:	
25/09/2008 08:06 AM	

Subject:	
[p2-dev] 3.4.1 incompatibilities?	
________________________________




Ciao Guys :)
I need your help once more, thanks a lot for anything you can give me to
resolve this! :)

We recently upped our target platforms to 3.4.1 to get the latest fixes.
Using that new version to generate an update repo seems to produce a
different result than before (3.4.1 M-build), as the RCP denies to
update itself with these message:

!ENTRY org.eclipse.equinox.p2.director 2 0 2008-09-25 13:47:08.250
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-09-25 13:47:08.250
!MESSAGE Unable to satisfy dependency from
toolingwin32.win32.x86org.eclipse.swt.gtk.solaris.sparc 3.4.1.v3449c to
requiredCapability:
osgi.bundle/org.eclipse.swt.gtk.solaris.sparc/3.4.1.v3449c.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-09-25 13:47:08.250
!MESSAGE Unable to satisfy dependency from
toolingwin32.win32.x86org.eclipse.swt.gtk.linux.x86 3.4.1.v3449c to
requiredCapability:
osgi.bundle/org.eclipse.swt.gtk.linux.x86/3.4.1.v3449c.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-09-25 13:47:08.250
!MESSAGE Unable to satisfy dependency from
toolingwin32.win32.x86org.eclipse.core.net.linux.x86 1.0.0.I20080521 to
requiredCapability:
osgi.bundle/org.eclipse.core.net.linux.x86/1.0.0.I20080521.

Looks like the windows RCP cannot update because of cross-platform
issues, a config win32/win32/x86 seems to have deps on
org.eclipse.swt.gtk.solaris.sparc now...

This might be entirely my fault and also irrelevant since our final
product will use 3.4.1 as a base, however, there  might be a bug lurking
there too which is why I decided to go with the "send mail first asking
whether to file a bugzilla" way here..

TIA,
Ciao, hh
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev




_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev

Attachment: screenshot.png
Description: screenshot.png