[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jetty-dev] hanging JGit HTTP tests using Jetty 8.1.3.v20120416

2012/5/29 Joakim Erdfelt <joakim@xxxxxxxxxxx>
I cannot replicate this problem.
(in other words: no build and/or test failures reported in maven)

What I did.

$ git cloneÂgit://git.eclipse.org/gitroot/jgit/jgit.git

 ÂNote: left clone on master

you need Âto checkout jgit origin/stable-2.0 in order to use Jetty 8.1.3

$ cd jgit
$ mvn clean install

This worked on:
* Ubuntu Oneiric (11.10) x64
 Âwith JDKÂ1.6.0_30-b12 (oracle, non-openjdk)
* Windows 7 (64 bit)
 Âwith JDK 1.7.0_02-b13 (oracle)

Both builds with maven 3.0.3

Question, why jetty 8.x?Â
None of the serviets appear to use servlet-3.0 specific features.
If you are not using servlet 3.0 then there is no reason to be using Jetty 8.x, stick with Jetty 7.x.

I tried that but wasn't able to install Jetty 7.x into 4.2 M7 or use it in a target platform
as 4.2 seems to bring and need 8.1.3. If I am wrong here I would be happy to roll back to 7.x
if someone can tell me how to use Jetty 7.x from within 4.2.
Â
  Note: Jetty 7.x and 8.x are developed in parallel, both experience releases at the same time.

I'm digging into your AppServer class right now to see if anything else jumps out.

--
Joakim Erdfelt
joakim@xxxxxxxxxxx

http://webtide.com | http://intalio.com
(the people behind jetty and cometd)



On Tue, May 29, 2012 at 6:11 AM, Matthias Sohn <matthias.sohn@xxxxxxxxxxxxxx> wrote:
we upgraded the JGit HTTP tests which used Jetty 7.1.6 so far to Â
JettyÂ8.1.3.v20120416 coming with Juno [1]. These tests start a Jetty server
with some JGit servlets from the JUnit's setup method and then send gitÂ
commands over HTTP in order to test jgit's HTTP transport protocolÂ
implementation.

On some machines (actually hudson.eclipse.org running on SLES and
Dani's windows PC) these tests hang when run using Jetty 8.1.3.v20120416.

Dani captured a thread dump of the latter case [2] [3]. The jgit test sends
a request similar (recorded on Mac where the tests do not hang) to:
GET /git/test1338294501573_0.git/info/refs HTTP/1.1
Accept-Encoding: gzip
Pragma: no-cache
User-Agent: JGit/unknown
Accept: */*
Cache-Control: no-cache
Host: 127.0.0.1:65167
Connection: keep-alive
and hangs waiting for a response. It seems the request doesn't
reach any of the JGit servlets. This didn't happen with the exact
same tests run on Jetty 7.1.6.

The expected response for the above request should look similar to
HTTP/1.1 200 OK
Expires: Fri, 01 Jan 1980 00:00:00 GMT
Pragma: no-cache
Cache-Control: no-cache, max-age=0, must-revalidate
Content-Type: text/plain;charset=UTF-8
Content-Length: 59
Server: Jetty(8.1.3.v20120416)

897816ec1f72959180c6082ac3431d51978e1378.refs/heads/master
Any idea what could be wrong ?
Any hints how to trouble shoot this problem ?
I also asked webmaster to get a thread dump on hudson [4] but this isn'tÂ
available yet

[1] JGit: - "Update Jetty to 8.1.3.v20120416" https://git.eclipse.org/r/#/c/6097/
EGit: - "Define target platforms for the build" https://git.eclipse.org/r/#/c/6098/

_______________________________________________
jetty-dev mailing list
jetty-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/jetty-dev



_______________________________________________
jetty-dev mailing list
jetty-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/jetty-dev




--
Matthias