[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[jetty-dev] hanging JGit HTTP tests using Jetty 8.1.3.v20120416

we upgraded the JGit HTTP tests which used Jetty 7.1.6 so far to Â
JettyÂ8.1.3.v20120416 coming with Juno [1]. These tests start a Jetty server
with some JGit servlets from the JUnit's setup method and then send gitÂ
commands over HTTP in order to test jgit's HTTP transport protocolÂ
implementation.

On some machines (actually hudson.eclipse.org running on SLES and
Dani's windows PC) these tests hang when run using Jetty 8.1.3.v20120416.

Dani captured a thread dump of the latter case [2] [3]. The jgit test sends
a request similar (recorded on Mac where the tests do not hang) to:
GET /git/test1338294501573_0.git/info/refs HTTP/1.1
Accept-Encoding: gzip
Pragma: no-cache
User-Agent: JGit/unknown
Accept: */*
Cache-Control: no-cache
Host: 127.0.0.1:65167
Connection: keep-alive
and hangs waiting for a response. It seems the request doesn't
reach any of the JGit servlets. This didn't happen with the exact
same tests run on Jetty 7.1.6.

The expected response for the above request should look similar to
HTTP/1.1 200 OK
Expires: Fri, 01 Jan 1980 00:00:00 GMT
Pragma: no-cache
Cache-Control: no-cache, max-age=0, must-revalidate
Content-Type: text/plain;charset=UTF-8
Content-Length: 59
Server: Jetty(8.1.3.v20120416)

897816ec1f72959180c6082ac3431d51978e1378.refs/heads/master
Any idea what could be wrong ?
Any hints how to trouble shoot this problem ?
I also asked webmaster to get a thread dump on hudson [4] but this isn'tÂ
available yet

[1] JGit: - "Update Jetty to 8.1.3.v20120416" https://git.eclipse.org/r/#/c/6097/
EGit: - "Define target platforms for the build" https://git.eclipse.org/r/#/c/6098/
[2] bug report: https://bugs.eclipse.org/bugs/show_bug.cgi?id=380302#c14 and ff
[3] thread dump: https://bugs.eclipse.org/bugs/attachment.cgi?id=216385
[4]Âhttps://bugs.eclipse.org/bugs/show_bug.cgi?id=380849

--
Matthias