[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Query in upgrading Equinox

If youâre starting to develop on OSGi you might want to checkout  [OSGi enRoute][1] (an OSGi project). It has many tutorials and examples to get started with OSGi (and Equinox) quickly.

Kind regards,

Peter Kriens

[1]: http://enroute.osgi.org


On 13 mei 2016, at 12:16, jayant sable <jayants232@xxxxxxxxx> wrote:

Just to understand.. If anyone have some time.. Can you explain flow of how osgi/equinox works. I'm new to this thing.. I searched Web but found not much related with the flow of osgi..

What I know is.. Some equinox container gets loaded first then all bundles are resolved and loaded.. There are some start level to each bundle.. 

So I'm certainly not clear about how equinox or osgi works. If someone can help me understand the equinox flow and how it can be used in any java application.. Then that would be very helpful..

Thanks,
Jay

On Thursday 12 May 2016, Thomas Watson <tjwatson@xxxxxxxxxx> wrote:
You probably should open a bug and give the details on how to reproduce.  A stacktrace may also help and the error log if it exists,  At this point I don't understand what is going wrong and I am not sure what to suggest.

With the Luna release (framework org.eclipse.osgi version 3.10) there was a major refactoring of the framework implementation.  It is certainly possible these changes introduced the situation that is causing your failure.

Tom





From:        jayant sable <jayants232@xxxxxxxxx>
To:        equinox-dev@xxxxxxxxxxx
Date:        05/12/2016 01:28 AM
Subject:        [equinox-dev] Query in upgrading Equinox
Sent by:        equinox-dev-bounces@xxxxxxxxxxx




Hi,

I'm using org.eclipse.osgi 3.8.1 jar in my project for bundle loading purpose.Now I'm trying to upgrade the equinox version to 3.10.1 but facing some issues. When I debug the code I found that some code in osgi class "ListenerQueue.class" is throwing ClassNotFound Exception for one the  bundle that I'm loading. I'll explain to the flow.

It starts from setStartLevel() in EclipseStarter class then it calls fwkStartLevel.setStartLevel()
from ModuleContainer class. After that flow goes to dispatchEventAsynchronous() in ListenerQueue class where It throws the exception in eventThread.PostEvent() method.

I really have now clue why its throwing Class not found exception.

Argument Which is going to eventThread.PostEvent() are 

osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.102.v20160118-1700"; singleton:="true" [id=0]=[Lorg.osgi.framework.FrameworkListener;@6b23cd35]=org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel@7b758986

with eventAction = 1 and eventObject = 6.

Can you help me with this as I'm stuck here and unable to find workaround.
Also how much different are the jars org.eclipse.osgi 3.8.1 and org.eclipse.osgi 3.10.1 from each other. Because I found on web that Various changes are made in latest equinox as compared to 3.8.1. And I suspect this is the reason why I'm unable to run my project.

Thanks,
Jay
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev


_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev

Attachment: smime.p7s
Description: S/MIME cryptographic signature