[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] equinox aspects/weaving in 3.4

Hi all,

I'm trying to use equinox aspects (recently renamed equinox weaving) with a 3.4.1-based target platform.   (Let me know if there's a better place for this question.  The site is out-of-date wrt recent changes.)

Quick-start instructions work fine in my Eclipse 3.5.1-based target platforms.  In 3.4.1-based platforms, there's no weaving.  The bundles are resolved but not active.  org.eclipse.equinox.weaving.

Is there a prior version of equinox-aspects that works under 3.4.1? 

aspectj-1.0.0.200906171200 requires org.eclipse.equinox.service.weaving package.  In 3.5 this is provided by org.eclipse.osgi - 3.5.1R35x_v20090827, but 3.4 does not have it in org.eclipse.osgi_3.4.2R34x_v20080826-1230.  Attempting to upgrade causes the p2 dependency solver to complain that the original version-specific constraints cannot be satisfied.  (And I'm not sure that's the only problem.)

If I change the 3.4 version requirements to permit the updated org.eclipse.orgi (and change the *.ini files), will it work?

Also, where's the CVS repository?  The new one (dev.eclipse.org:/cvsroot/rt/org.eclipse.equinox) doesn't seem to work,and I see no incubating components in the old one.

Thanks!

References:
site?: http://www.eclipse.org/equinox/incubator/aspects/index.php
quickstart: http://www.eclipse.org/equinox/incubator/aspects/equinox-aspects-quick-start.php
rename: https://www.blogger.com/comment.g?blogID=18490491&postID=2734033852728096950&page=0&token
migration: http://wiki.eclipse.org/Equinox_Eclipse_to_RT_Migration