[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] org.eclipse.osgi_3.4.2.R34x_v20080826-1230 defines ExecutionEnvironment: J2SE-1.5

Hi Heiko,

The reason this was added was to avoid compilation errors when importing org.eclipse.osgi into your workspace as source from the target SDK. The org.eclipse.osgi project supports the OSGi minimum 1.1 execution environment but will make use of additional classes from J2SE 1.4 and 1.5 if they are available (e.g. https://bugs.eclipse.org/bugs/show_bug.cgi?id=133048). When importing the bundle as source from the target SDK it gets compiled against J2SE 1.5 for convenience (PDE uses the first EE listed in the BREE as the default VM to compile against).

The org.eclipse.osgi project in CVS contains the OSGi minimum 1.1 execution environment jar plus some additional stubbed classes to compile against. We wanted to avoid having to ship these stub jars in order to import org.eclipse.osgi as source and we wanted to avoid forcing the average developer from finding a minimun execution environment to compile against.

I am curious why this is causing issues with your test cases. The BREE header used to list only OSGi/Minimum-1.1. Now it also lists J2SE-1.5. Semantically there is no difference because OSGi/Minumum-1.1 is a proper subset of J2SE-1.5. A bundle that states it can run on OSGi/Minimum-1.1 is also implying that it can run on J2SE-1.3 or higher.

Tom



Inactive hide details for Heiko Seeberger ---10/10/2008 03:13:48 AM---Hi,Heiko Seeberger ---10/10/2008 03:13:48 AM---Hi,


From:

Heiko Seeberger <heiko.reg@xxxxxxxxxxxxx>

To:

Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

Date:

10/10/2008 03:13 AM

Subject:

[equinox-dev] org.eclipse.osgi_3.4.2.R34x_v20080826-1230 defines ExecutionEnvironment: J2SE-1.5




Hi,

After updating to 3.4.1 I had some issues with my test cases for  
Equinox Aspects. The reason was, that the latest version of the system  
bundle now defines Java 5 as the first execution environment:
Bundle-RequiredExecutionEnvironment: J2SE-1.5,OSGi/Minimum-1.1

Is this by intention? If yes, why?

Heiko

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev


GIF image

GIF image