[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] [Equinox Security] Error while running unit tests of JCA/JAAS_framework_contribution

Hi,

 

(I tried sending this post to eclipse.technology.equinox  newsgroup but got no answers. Sorry for this cross-posting then…)

 

 

I'm trying to run junit tests of milestone M3 of equinox security. I followed the  directions presented in the wiki page (http://wiki.eclipse.org/Security:_JCA/JAAS_framework_contribution).

Unfortunately, I get the exceptions presented in the stack trace below.

Environment is:

Eclipse 3.4.0
Windows Vista
JRE 1.5.0_06

Any help would be appreciated.

Regards,
Ricardo Giacomin


!SESSION 2008-08-22 16:17:33.257 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.5.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -version 3 -port 55474 -testLoaderClass org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestLoader -loaderpluginname org.eclipse.jdt.junit.runtime -testNameFile C:\Users\Giacomin\AppData\Local\Temp\testNames4844.txt -application org.eclipse.pde.junit.runtime.uitestapplication -product org.eclipse.sdk.ide -testpluginname org.eclipse.equinox.security.junit
Command-line arguments:  -os win32 -ws win32 -arch x86 -version 3 -port 55474 -testLoaderClass org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestLoader -loaderpluginname org.eclipse.jdt.junit.runtime -testNameFile C:\Users\Giacomin\AppData\Local\Temp\testNames4844.txt -application org.eclipse.pde.junit.runtime.uitestapplication -product org.eclipse.sdk.ide -data C:\Users\Giacomin\osgi/../junit-workspace -dev file:C:/Users/Giacomin/osgi/.metadata/.plugins/org.eclipse.pde.core/pde-junit/dev.properties -os win32 -ws win32 -arch x86 -testpluginname org.eclipse.equinox.security.junit

!ENTRY org.eclipse.osgi 4 0 2008-08-22 16:17:37.539
!MESSAGE !STACK 0
org.osgi.framework.BundleException: Cannot attach fragment bundle "org.eclipse.equinox.security.boot.jre15x" to resolved host "org.eclipse.osgi".  Try refreshing the host bundle.
at org.eclipse.osgi.framework.internal.core.BundleHost.attachFragment(BundleHost.java:575)
at org.eclipse.osgi.framework.internal.core.BundleFragment.addHost(BundleFragment.java:298)
at org.eclipse.osgi.framework.internal.core.PackageAdminImpl.setResolved(PackageAdminImpl.java:337)
at org.eclipse.osgi.framework.internal.core.PackageAdminImpl.applyDeltas(PackageAdminImpl.java:353)
at org.eclipse.osgi.framework.internal.core.PackageAdminImpl.processDelta(PackageAdminImpl.java:441)
at org.eclipse.osgi.framework.internal.core.PackageAdminImpl.doResolveBundles(PackageAdminImpl.java:221)
at org.eclipse.osgi.framework.internal.core.PackageAdminImpl$1.run(PackageAdminImpl.java:164)
at java.lang.Thread.run(Thread.java:595)

!ENTRY org.eclipse.core.runtime 4 0 2008-08-22 16:17:37.990
!MESSAGE !STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.app; bundle-version="[1.0.0,2.0.0)"
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:351)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1061)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:632)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:506)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:280)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:466)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:209)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:319)