[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] Calling p2 director by command line freezes Eclipseon splash screen

Hi Paul,

Thanks for your reply.

I never tried to wait that much but I'll try right now and also the
eclipsec.exe alternative.
As soon as I have this tested I'll report the results here.

Just to let you know, I'm trying to install only one feature installation
(just to test if the command line works), that is the Hello World main menu
example given on Eclipse plug-ins creation wizard.

Thanks,

Pedro Carneiro.





Warren.Paul wrote:
> 
> Are you sure it's freezing?  From my experience it can take 10+ minutes
> to run, although we have a rather large set of features.  Maybe you can
> try running eclipsec.exe instead and giving it more time?
> 
> Thanks,
> Warren 
> 
> -----Original Message-----
> From: equinox-dev-bounces@xxxxxxxxxxx
> [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of ext Pedro Carneiro
> Sent: Monday, June 16, 2008 8:14 AM
> To: equinox-dev@xxxxxxxxxxx
> Subject: [equinox-dev] Calling p2 director by command line freezes
> Eclipseon splash screen
> 
> 
> Hi all,
> 
> I am trying to call the p2 director by command line to install a feature
> using p2 (I suppose this is the substitute of the old update manager).
> 
> I was following the "Installing software using the p2 director
> application"
> tutorial (available on Eclipse Help Contents > Platform Plug-in
> Developer Guide > Programmer's Guide > Packaging and delivering Eclipse
> based products
>> Provisioning platform (p2)) but without success.
> 
> question 1: Is the mentioned tutorial out of date?
> 
> I'm using the command line below:
> 
> D:\eclipse_ganymede_RC4\eclipse>eclipse.exe -application
> org.eclipse.equinox.p2.director.app.application -metadataRepository
> file:/d:/myUS34 -artifactRepository file:/d:/myUS34 -installIU
> myFeature34.feature.group -version 1.0.0 -destination
> d:/eclipse_ganymede_RC4/eclipse -profile SDKProfile
> 
> This command is freezing Eclipse in the splash screen. No log is created
> showing error messages, so I don't know what is happening.
> 
> Does anyone knows what could be rising this freeze?
> 
> Thanks,
> 
> Pedro Carneiro
> --
> View this message in context:
> http://www.nabble.com/Calling-p2-director-by-command-line-freezes-Eclips
> e-on-splash-screen-tp17864191p17864191.html
> Sent from the Equinox - Dev mailing list archive at Nabble.com.
> 
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
> 
> 

-- 
View this message in context: http://www.nabble.com/Calling-p2-director-by-command-line-freezes-Eclipse-on-splash-screen-tp17864191p17865875.html
Sent from the Equinox - Dev mailing list archive at Nabble.com.