[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] [prov] p2 provisioned eclipse missing companion library

You should be able to find good p2 data at
http://update.eclipse.org/eclipse/testUpdates/



                                                                                                                                             
  From:       Timothy Webb <tim@xxxxxxxxxx>                                                                                                  
                                                                                                                                             
  To:         Equinox development mailing list <equinox-dev@xxxxxxxxxxx>                                                                     
                                                                                                                                             
  Date:       01/31/2008 04:44 PM                                                                                                            
                                                                                                                                             
  Subject:    Re: [equinox-dev] [prov] p2 provisioned eclipse missing     companion   library                                                
                                                                                                                                             





Pascal,

Thanks for the pointers.  The eclipse.ini as well as other files are
indeed being dropped down by p2.  Perhaps this is an issue that
relates to the metadata generator producing output that is not
expected.  How and when did you last generate the p2 metadata you are
running against?

Here's what I see for the toolingorg.eclipse.launcher...'s touchpoints:

<touchpoint id="native" version="1.0.0"/>
<touchpointData size="1">
   <instructions size="2">
     <instruction key="uninstall">
             cleanupzip(source:@artifact, target:${installFolder});
     </instruction>
     <instruction key="install">
             unzip(source:@artifact, target:${installFolder});
     </instruction>
   </instructions>
</touchpointData>

And for the org.eclipse.launcher...'s touchpoints:

<touchpoint id="native" version="1.0.0"/>
(and that's it)

Is there a public "known good" p2 site that I can validate against?
It looks like the milestone site still doesn't have p2 format data
available.

 From what I'm seeing, the currently checked-in metadata generator is
not including the addProgramArg instructions to the
org.eclipse.launcher... IUs' touchpoints as should be indicated by the
code in EclipseInstallGenerator.  I will continue digging but I am
curious what version of the generator others are using to perform
their testing.

I've tested regenerating the meta using the current code against both
an Eclipse 3.3 as well as 3.4M4 build with the same result.

Thanks,
Tim

On Jan 31, 2008, at 3:14 PM, Pascal Rapicault wrote:

> John and I have been doing that since M3 (some hickups of course
> occured)
> and that worked and I confirm that yesterday's build works as well.
> However we are deploying a 3.4 eclipse and not a 3.3.
> Normally when p2 installs the SDK, a -startup and -launcher.library
> arguments are being set to point ot the jar.
>
> You say: In our eclipse.ini file we drop down next to the exe,
> Do you actually drop the ini file? If so this is the pb. The ini
> files are
> no longer file that you lay down. Instead they result from the
> installation
> of some IUs (for example, see the
> toolingorg.eclipse.equinox.launcher IU)
>
> HTH,
>
> PaScaL
>
>
> |------------>
> | From:      |
> |------------>
>>
--------------------------------------------------------------------------------------------------------------------------------------------------|

>  |Timothy Webb
> <
> tim
> @trwebb
> .com
> >
>
|
>>
--------------------------------------------------------------------------------------------------------------------------------------------------|

> |------------>
> | To:        |
> |------------>
>>
--------------------------------------------------------------------------------------------------------------------------------------------------|

>  |Equinox development mailing list <equinox-
> dev
> @eclipse
> .org
> >
>
|
>>
--------------------------------------------------------------------------------------------------------------------------------------------------|

> |------------>
> | Date:      |
> |------------>
>>
--------------------------------------------------------------------------------------------------------------------------------------------------|

>  |01/31/2008 03:47
> PM
>
|
>>
--------------------------------------------------------------------------------------------------------------------------------------------------|

> |------------>
> | Subject:   |
> |------------>
>>
--------------------------------------------------------------------------------------------------------------------------------------------------|

>  |[equinox-dev] [prov] p2 provisioned eclipse missing companion
> library
>
|
>>
--------------------------------------------------------------------------------------------------------------------------------------------------|

>
>
>
>
>
> Are others having success using p2 to provision an Eclipse where the
> cache directory is not collocated with the eclipse exe?
>
> I'm running into an issue where despite having what appears to be the
> right set of software downloaded in the cache, configured in the
> platform.xml / config.ini, etc., each time I try to run the
> eclipse.exe, I receive "The eclipse executable launcher was unable to
> locate its companion launcher jar."  In looking through the C code for
> the launcher, it looks like Eclipse is designed to search for the
> companion library in the plugins area, located near the exe, or by
> specifying --launcher.library on the command line.  In our eclipse.ini
> file we drop down next to the exe, I don't see a --launcher.library
> argument configured.  Is this something that should be setup by
> default in the normal touchpoints?  Or, is there a branch of the
> Eclipse.exe that is designed to work better with p2-style deployments?
>
> Thanks,
> Tim
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>
>
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev