[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Plugin project not appearing in console

Thanks for this. My reply inline below.

On Mon, 2007-05-07 at 08:36 +0100, Alex Blewitt wrote:
> Possibly a problem with your launch configuration that you're using.
> When you look at that, what bundles are selected for running?

I doubt it. I've tried rebuilding the launch file (as well as all the
projects) from scratch. I pasted the contents of the file below.


> You can launch it with -clean on the runtime PDE instance (there's an
> option on the launch config, via Run->Run...) and check to  make sure
> you're including it e.g. via the bundles.

Yup, did all that.


> It would be interesting to know what the launch config looks like,
> such as whether your config points to this bundle as a kind of Windows
> URL which therefore doesn't resolve on a Linux box. If it's a project
> in your workspace, this shouldn't be an issue (but might be).

Thanks, Alex.

Here are the contents of the launch file:


<?xml version="1.0" encoding="UTF-8"?>
<launchConfiguration type="org.eclipse.pde.ui.EquinoxLauncher">
<intAttribute key="default_start_level" value="4"/>
<stringAttribute key="bootstrap" value=""/>
<booleanAttribute key="tracing" value="false"/>
<stringAttribute key="org.eclipse.jdt.launching.PROGRAM_ARGUMENTS"
value="-console"/>
<stringAttribute key="org.eclipse.jdt.launching.VM_ARGUMENTS"
value="-Dorg.osgi.service.http.port=8080
-Dbundles.configuration.location=
${workspace_loc:/lsd-autocomplete/configurations} -Xmx512m"/>
<booleanAttribute key="clearConfig" value="true"/>
<booleanAttribute key="automaticValidate" value="false"/>
<booleanAttribute
key="org.eclipse.debug.core.appendEnvironmentVariables" value="true"/>
<booleanAttribute key="useDefaultConfigArea" value="true"/>
<stringAttribute key="org.eclipse.jdt.launching.SOURCE_PATH_PROVIDER"
value="org.eclipse.pde.ui.workbenchClasspathProvider"/>
<stringAttribute key="target_bundles"
value="org.eclipse.equinox.servlet.api@default:default,org.eclipse.osgi@:,org.eclipse.osgi.services@default:default,org.junit@default:default,org.junit4@default:default,org.ungoverned.osgi.bundle.http@default:default"/>
<stringAttribute key="workspace_bundles"
value="json@default:default,kf_junit@default:default,org.ops4j.pax.logging.api@default:default,org.ops4j.pax.logging.jcl@default:default,org.ops4j.pax.logging.log4j@default:default,org.ops4j.pax.logging.service@default:default,org.ops4j.pax.wicket.service@default:default"/>
<booleanAttribute key="automaticAdd" value="false"/>
<booleanAttribute key="default_auto_start" value="true"/>
<stringAttribute key="checked" value="[NONE]"/>
<booleanAttribute key="includeOptional" value="true"/>
<stringAttribute key="configLocation" value=""/>
</launchConfiguration>