[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] Servlet API support

The OSGi HttpService requires a minimum of Servlet 2.1 support.
The org.eclipse.equinox.http bundle provides just such a minimal implementation and is tiny in terms of its overall size.
The trade-off is that it doesn't support the Servlet API beyond 2.1. Changes were put in the code so that it would still be able to resolve against a higher Servlet API albeit throws UnsupportedOperationExceptions for the use of those methods.
 
If you want an Http Service that supports Servlet 2.4 you can use the Jetty based implementation e.g. org.eclipse.equinox.http.jetty.
See http://www.eclipse.org/equinox/server/http_in_equinox.php (I'd recommend using the teamset to collect up the right dependencies)
 
HTH
-Simon


From: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Nikunj Mehta
Sent: Wednesday, November 01, 2006 1:00 PM
To: equinox-dev@xxxxxxxxxxx
Subject: [equinox-dev] Servlet API support

The equinox bundle org.eclipse.equinox.servlet.api_1.0.0 containing the servlet API says that it exports javax.servlet; version =2.3 and javax.servlet.http; version =2.3.

However, none of the >2.1 servlet API features work when using org.eclipse.equinox.http_1.0.100 bundle and result in
java.lang.UnsupportedOperationException: HttpService only supports servlet 2.1 specification.

Can someone throw light on the reason behind such behavior?

Nikunj
 
     This message may contain privileged and/or confidential information.  If you have received this e-mail in error or are not the intended recipient, you may not use, copy, disseminate or distribute it; do not open any attachments, delete it immediately from your system and notify the sender promptly by e-mail that you have done so.  Thank you.