[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] EventAdmin ServiceReference is always null?


Hi Cameron,

You are missing the implementation of EventAdmin.  You need the following bundle from the equinox download site (the same place you got org.eclipse.equinox.log).

org.eclipse.equinox.event

You need to make sure this bundle is started so it can register the EventAdmin service.

Tom




"Cameron Ross" <cross@xxxxxxxxxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

05/12/2006 08:28 AM

Please respond to
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

To
<equinox-dev@xxxxxxxxxxx>
cc
Subject
[equinox-dev] EventAdmin ServiceReference is always null?





Hello,
 
I am unable to obtain a valid ServiceReference for the EventAdmin service shipped with 3.2RC3.  The start method in my Activator class looks like this:
 
public void start(BundleContext context) throws Exception {
   ServiceReference serviceRef = context.getServiceReference(EventAdmin.class.getName());    

    // serviceRef is always null!
}

 
The following items are selected in both the Eclipse "Window->Preferences->Plug-in Development->Target Platform->Plug-ins" and "Run->Run...->Plug-ins->Target Platform" areas:
  - org.eclipse.equinox.log(1.0.0.v20060206)
  - org.eclipse.osgi(3.2.0.v20060505)
  - org.eclipse.osgi.services(3.1.100.20060426)
 
My manifest contains the following header and everything compiles nicely:
    Import-Package: org.osgi.framework, org.osgi.service.event, org.osgi.util.tracker
 
I'm running Eclipse 3.2-RC3 (Version 3.2.0, Build ID I20060505-1306) with Sun's JRE 1.5.0_06 on Windows XP Professional SP2.  
 
Note that I am able to get a ServiceReference to the LogService.  Any help is greatly appreciated.
 
Thanks,
Cameron Ross.

 _______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev