[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] Can't compile org.eclipse.equinox.http

Tried it again using I20060131-1200 with the same result.  Filed the following bugs:
 
Eclipse doesn't use available libs when it should
https://bugs.eclipse.org/bugs/show_bug.cgi?id=126294

Compile errors not indicated in Package Explorer for all files with errors
https://bugs.eclipse.org/bugs/show_bug.cgi?id=126295


From: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Jeff McAffer
Sent: Wednesday, February 01, 2006 8:02 PM
To: Equinox development mailing list
Subject: RE: [equinox-dev] Can't compile org.eclipse.equinox.http


Ron,

Yes, I have seen similar kinds of behaviour.  There were some changes released into this weeks integration build.  Could you do us a favour and get the build and try it on your workspace?  If you still see the problem, please open a bug report in JDT UI with the steps/setup/build info.  It helps to have multiple inputs on this to get different characteristics.

Either way, please report what happens in this list.  Thanks!

Jeff



"Ron Baldwin" <Ron.Baldwin@xxxxxxxxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

02/01/2006 04:56 PM

Please respond to
Equinox development mailing list

To
"Equinox development mailing list" <equinox-dev@xxxxxxxxxxx>
cc
Subject
RE: [equinox-dev] Can't compile org.eclipse.equinox.http





It looks like Eclipse can get confused and not use an available library when it needs to.  I have these bundles in my workspace:
 
   1) org.eclipse.equinox.http (from CVS HEAD)
   2) org.eclipse.tomcat (binary linked import from 3.2 M4)
   3) javax.servlet (created by me to export Tomcat 5's servlet.jar)
 
The Http bundle should be able to compile against either #2 or #3.  If I close either #2 or #3 (but not both), Http still compiles.  As soon as I close the remaining open project, Http gets compile errors.  So far so good.  Now, I should be able to open either #2 or #3 and the Http compile errors should go away.  However, they only go away if I open #3.  At the moment, this is repeatable, but I'm not sure it's repeatable over time.  I wouldn't be surprised to try it later and find that opening #2 is the only way it works (or maybe opening either works).
 
Also, like I said before, when Http gets compile errors they only show up in Package Explorer on a single file, but errors show up in the editor for the others.
 
Ron
 


From: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Jeff McAffer
Sent:
Friday, January 27, 2006 8:59 PM
To:
Equinox development mailing list
Subject:
Re: [equinox-dev] Can't compile org.eclipse.equinox.http



Ron,


The fact that only some files show errors in the Package Explorer feels like a bug in the JDT UI.  Please enter a bug report (with build etc info) if you can reproduce.


When you have been compiling it before, what JRE have you been using?  Conversely, what has your target platform been set to?  If the target platform has the org.eclipse.tomcat bundle then this bundle is supplying the javax.servlet packages.  If you then changed the target somehow to not have tomcat (or tomcate is somehow unresolved), the servlet packages would no longer be exported and the HTTP service bundle would be unhappy.


Jeff



Jennifer Fogell <jfogell@xxxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

01/27/2006 04:40 PM

Please respond to
Equinox development mailing list


To
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>
cc
Subject
Re: [equinox-dev] Can't compile org.eclipse.equinox.http








Hopefully the solution to Eclipse bug #121585 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=121585) will solve this problem.  We are going to separate the servlet APIs out of TomCat.


regards,
Jennifer Fogell
OSGi Extensions Lead
IBM Device Software Development


"Ron Baldwin" <Ron.Baldwin@xxxxxxxxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

01/27/2006 03:24 PM
Please respond to Equinox development mailing list

       
      To:        <equinox-dev@xxxxxxxxxxx>

      cc:        

      Subject:        [equinox-dev] Can't compile org.eclipse.equinox.http





I pulled org.eclipse.equinox.http from CVS a couple of days ago,
compiled it and have been successfully using it.  Then, today out of
nowhere it has decided that it can't compile because it can't find
javax.servlet.  I haven't done anything (that I know of) that would have
caused this.

Even weirder is that the only file in the project that's marked with an
x in Package Explorer is ServletContextImpl.java, although the other
files that use javax.servlet will show errors if you open them in the
editor.

Any ideas?

Thanks,
Ron
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev