[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [egit-dev] How to build current egit / jgit - unable to find org.apache.commons.compress.archivers.zip

org.eclipse.jgit.api.ArchiveCommand doesn't yet exist probably since
Jonathan first wanted to use it from command line, see Âthe discussion
on the jgit list [1]. If you have more questions on this topic ask that on
the jgit list since I doubt that Jonathan is watching the egit list.

[1]Âhttp://dev.eclipse.org/mhonarc/lists/jgit-dev/msg01918.html

--
Matthias

2012/12/10 Tomasz Zarna <tzarna@xxxxxxxxx>
> use Apache commons compress and the jgit pgm

Out of curiosity, why is this required by pgm in the first place?
Shouldn't the project depend solely on org.eclipse.jgit.* packages (+
args4j)? As far as I'm concerned the guts of
org.eclipse.jgit.pgm.Archive should be in
org.eclipse.jgit.api.ArchiveCommand.

Cheers,
Tomasz

On Mon, Dec 10, 2012 at 3:43 PM, Matthias Sohn
<matthias.sohn@xxxxxxxxxxxxxx> wrote:
> 2012/12/10 Robert Munteanu <robert.munteanu@xxxxxxxxx>
>>
>> Hi,
>>
>> Currently the EGit Hudson build fails [1] due to a missing p2 dependency
>>
>> "No solution found because the problem is unsatisfiable.": ["Unable to
>> satisfy dependency from org.eclipse.jgit.pgm 2.2.0.201212100959 to
>> package org.apache.commons.compress.archivers [1.3.0,2.0.0).", "Unable
>> to satisfy dependency from org.eclipse.jgit.pgm 2.2.0.201212100959 to
>> package org.apache.commons.compress.archivers.tar [1.3.0,2.0.0).",
>> "Unable to satisfy dependency from org.eclipse.jgit.pgm
>> 2.2.0.201212100959 to package
>> org.apache.commons.compress.archivers.zip [1.3.0,2.0.0).", "No
>> solution found because the problem is unsatisfiable."]
>>
>> The latest Orbit S-Build [2] does provide have the commons-compress
>> bundle.
>>
>> How can I build the current jgit/egit codebase? I would like to verify
>> some bugs which exist in 2.1 and see if they are fixed with 2.2 .
>>
>> Thanks,
>>
>> Robert
>>
>> [1]: https://hudson.eclipse.org/hudson/job/egit/
>> [2]:
>> http://download.eclipse.org/tools/orbit/downloads/drops/S20121207152029/
>
>
> we've got the approval to use Apache commons compress and the jgit pgm build
> succeeds
> since it compiles against Maven central. But the egit build tries to package
> this library
> into its p2 repository for OSGi consumers and this fails since this library
> isn't yet available
> from Orbit. Chris wanted to care for publishing this lib in Orbit but it
> seems he didn't yet find
> time to work on that.
>
> I pushed [1] as a workaround marking org.eclipse.jgit.pgm's dependencies to
> apache commons
> compress as optional as a temporary fix for the failing egit p2 repository
> build. As soon
> as apache commons compress is available we can revert this change.
>
> [1] https://git.eclipse.org/r/9138
>
> --
> Matthias
>
> _______________________________________________
> egit-dev mailing list
> egit-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/egit-dev
>



--
Matthias