[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[eclipselink-dev] Hermes JPQL Parser Bundles

Hi All,

As you probably know, we recently changed our JPQL parser from the ANTLR-based version that shipped in EclipseLink 2.3.x and prior releases to our new Hermes Parser which we share with the Dali project.

  Hermes currently ships as two bundles.

1. The org.eclipse.persistence.jpa.jpql bundle - this is the Hermes parser used by EclipseLink and Dali. It has no dependencies on other EclipseLink code.

2. The org.eclipse.persistence.core.jpql fragment - this is glue code that makes use of the Hermes parser to build queries at EclipseLink runtime.

Since Hermes is now the default parser, it does not make sense that part of it be maintained in a fragment. I propose we move the all the org.eclipse.persistence.core.jpql code to our core bundle.

The following bug has been entered to track this suggestion.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=377641

If you have concerns, please add comments to the bug.

-Tom