Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [dali-dev] changing jpaPlatform extension points

While we're changing things ... :)

Perhaps not now, but in the near future we're going to need to support platform versioning in a more robust way.  In 2.2 we're going to support multiple versions of EclipseLink in at least a minimal way, but there are things we can do to help the future transition.

This bug describes how I think the *future* support would look: https://bugs.eclipse.org/bugs/show_bug.cgi?id=262663

Among the things we could do *now* to defer having to implement this for this release:
  • Currently we store the platform a project has in the project preferences under the key "org.eclipse.jpt.core.platform".  In order to maintain backwards compatibility for user projects, this should probably be conserved, but we could store new platform versions using some kind of version notation (for example, "org.eclipse.eclipselink.platform:1.1".)   Alternatively, we could provide an alias field on platform version extensions to read in and convert old platforms to the new nomenclature.  (Actually this would be helpful for use in existing functionality enablement (e.g. property testers) extensions.)

Also (and I know this is late - sorry) I think we should change the ui extension to "jpaPlatformUi" and the field "jpaPlatformId" to just "jpaPlatform".

- Paul

Karen Moore wrote:
I have checked these changes in, the bug explains the changes that were made.  This will be in the 2.2M5 release and includes changing the names of the extension points.  I am assuming community silence means consent to the changes :)

thanks,
Karen

Karen Moore wrote:

Hi,

I am looking at https://bugs.eclipse.org/226570 and changing the core.jpaPlatform and ui.jpaPlatform extension points.  The bug explains the couple of changes I plan to make and includes an attachment.  This is being done in our effort to support multiple JPA versions in the future.  Sending this out so extenders know they will have to react in 2.2M5 and so we can discuss if the changes make sense.  Beyond the patch attached to the bug I am trying to determine if the extension point name or jpaPlatform element name should change as well.

   <extension point="org.eclipse.jpt.core.jpaPlatform">
       <jpaPlatform
           id="generic"
           label="%GENERIC_PLATFORM_LABEL"
           factoryClass="org.eclipse.jpt.core.internal.platform.GenericJpaPlatformFactory"
           default="false"/>
   </extension>

   <extension point="org.eclipse.jpt.ui.jpaPlatform">
       <jpaPlatform
           id="generic.ui"
           jpaPlatformId="generic"
           factoryClass="org.eclipse.jpt.ui.internal.platform.generic.GenericJpaPlatformUiFactory"/>
   </extension>

I have noticed other extension points tend to be plural, but not sure there is really a pattern there.  Also, is there a better name for the element jpaPlatform?  Potentially jpaPlatformFactory/jpaPlatformUiFactory and then the factoryClass attribute would be renamed to class.  I am not completely sold on this idea since the attributes specified in jpaPlatformFactory really pertain to the platform not the factory.  I am looking for suggestions here.

Thanks,
Karen
_______________________________________________
dali-dev mailing list
dali-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/dali-dev

_______________________________________________
dali-dev mailing list
dali-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/dali-dev


-- 
Paul Fullbright
Eclipse Java Persistence Tools (Dali) Development
Oracle

Back to the top