Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[dali-dev] changing jpaPlatform extension points

Hi,

I am looking at https://bugs.eclipse.org/226570 and changing the core.jpaPlatform and ui.jpaPlatform extension points. The bug explains the couple of changes I plan to make and includes an attachment. This is being done in our effort to support multiple JPA versions in the future. Sending this out so extenders know they will have to react in 2.2M5 and so we can discuss if the changes make sense. Beyond the patch attached to the bug I am trying to determine if the extension point name or jpaPlatform element name should change as well.

   <extension point="org.eclipse.jpt.core.jpaPlatform">
       <jpaPlatform
           id="generic"
           label="%GENERIC_PLATFORM_LABEL"
factoryClass="org.eclipse.jpt.core.internal.platform.GenericJpaPlatformFactory"
           default="false"/>
   </extension>

   <extension point="org.eclipse.jpt.ui.jpaPlatform">
       <jpaPlatform
           id="generic.ui"
           jpaPlatformId="generic"
factoryClass="org.eclipse.jpt.ui.internal.platform.generic.GenericJpaPlatformUiFactory"/>
   </extension>

I have noticed other extension points tend to be plural, but not sure there is really a pattern there. Also, is there a better name for the element jpaPlatform? Potentially jpaPlatformFactory/jpaPlatformUiFactory and then the factoryClass attribute would be renamed to class. I am not completely sold on this idea since the attributes specified in jpaPlatformFactory really pertain to the platform not the factory. I am looking for suggestions here.

Thanks,
Karen


Back to the top