[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [aspectj-users] AspectJ with Ganymede: 1.6.1... or 1.6.0... ?

Hello Heinz,

The are two version numbers to keep in mind. One is the AJDT version and the other is the version of AspectJ that is embedded with that AJDT version.

For Eclipse 3.3 we are currently on AJDT 1.5.3 which embeds AspectJ 1.6.1.
For Eclipse 3.4 we are working on AJDT 1.6.0 which also embeds AspectJ 1.6.1.

There are currently some issues with the Eclipse 3.4 update site because of P2, we are working on them right now.

Andy.

2008/8/18 Heinz-Günter Kuper <heinz.kuper@xxxxxxxxxxxxxxxx>
Details of my system:
Mac OS 10.5.4
Eclipse 3.4
Java SE 6

Greetings,

I have just installed Ganymede and was trying to get AspectJ running (as I was using it in my Europa installation). I realise there is no official AJDT release for Eclipse 3.4 yet, but I am a little confused by the information to be found at <http://www.eclipse.org/ajdt/downloads/>.

Under the section "Development builds for Eclipse 3.4" there is talk of AspectJ Version 1.6.1.20080514120000, but when I enter the Update Site URL <http://download.eclipse.org/tools/ajdt/34/dev/update> it points me to version 1.6.0.200808161224. And if I try to install that version of the AspectJ plugin, I get all sorts of unsatisfied dependencies (details at the end of this mail). I would prefer to use the update site, but if it comes to the worst I suppose I could install 'by hand' from CVS.

Any and all assistance would be greatly appreciated.

Thanks,
Heinz


Error message when trying to install from <http://download.eclipse.org/tools/ajdt/34/dev/update>:
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.aspectj.weaver 1.6.2.20080807114600] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.ui 1.5.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.visualiser 2.2.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.core 1.5.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.core 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.aspectj.weaver 1.6.2.20080807114600] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.ui 1.5.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.core 1.5.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.core 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.aspectj.weaver 1.6.2.20080807114600] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.mylyn.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.eclipse.contribution.xref.ui/1.5.0
Unsatisfied dependency: [org.eclipse.ajdt.mylyn.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.eclipse.ajdt.ui/1.6.0
Unsatisfied dependency: [org.eclipse.ajdt.mylyn.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.eclipse.ajdt.core/1.6.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.weaver/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.eclipse.ajdt.core/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.eclipse.contribution.xref.core/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808161224] requiredCapability: osgi.bundle/org.eclipse.contribution.xref.ui/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.core 1.5.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.core 1.6.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.ui 1.5.0.200808161224] requiredCapability: osgi.bundle/org.eclipse.contribution.xref.core/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.ui 1.5.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.examples 1.6.0.200808161224] requiredCapability: osgi.bundle/org.eclipse.ajdt.ui/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.visualiser 2.2.0.200808161224] requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ajdt.core/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.contribution.xref.core/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ajdt.examples/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.contribution.visualiser/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ajdt.mylyn.ui/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.aspectj.weaver/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.contribution.xref.ui/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group 1.6.0.200808161224] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ajdt.ui/0.0.0




_______________________________________________
aspectj-users mailing list
aspectj-users@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/aspectj-users