Bug 302195 - Getter naming conventions
Summary: Getter naming conventions
Status: RESOLVED FIXED
Alias: None
Product: Equinox
Classification: Eclipse Project
Component: p2 (show other bugs)
Version: 3.6   Edit
Hardware: All All
: P3 normal (vote)
Target Milestone: 3.6 M6   Edit
Assignee: Pascal Rapicault CLA
QA Contact:
URL:
Whiteboard:
Keywords: api
Depends on:
Blocks:
 
Reported: 2010-02-08 16:52 EST by Filip Hrbek CLA
Modified: 2010-02-26 13:29 EST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Hrbek CLA 2010-02-08 16:52:35 EST
All getters on IInstallableUnit are named after the type of the returned collection's item. For historical reasons, there are two exceptions though:

Collection<IRequirement> getMetaRequiredCapabilities();
Collection<IRequirement> getRequiredCapabilities();

To make the naming conventions consistent, the methods should me renamed to

Collection<IRequirement> getMetaRequirements();
Collection<IRequirement> getRequirements();
Comment 1 Pascal Rapicault CLA 2010-02-08 19:27:12 EST
If there is no objection I will do such a change
Comment 2 Pascal Rapicault CLA 2010-02-26 13:29:40 EST
Fixed in HEAD.