Bug 99683

Summary: [extract constant] uses wrong naming conventions
Product: [Eclipse Project] JDT Reporter: Tobias Widmer <tobias_widmer>
Component: UIAssignee: Markus Keller <markus.kell.r>
Status: RESOLVED WORKSFORME QA Contact:
Severity: normal    
Priority: P3    
Version: 3.1   
Target Milestone: 3.3 M7   
Hardware: PC   
OS: All   
Whiteboard:
Bug Depends on: 85946    
Bug Blocks:    

Description Tobias Widmer CLA 2005-06-13 11:09:01 EDT
3.1 RC2

package p;

import java.util.ArrayList;
import java.util.List;

public class Test {
	public void foo() {
		List<String> list= new ArrayList<String>();
	}
}

- Invoke Extract Constant on the class instance creation

-> Proposed name uses prefix/suffix of local variables.
-> It should use prefix/suffix for static fields
Comment 1 Dirk Baeumer CLA 2005-06-13 17:53:49 EDT
Unhappy, but not critical enough for RC3.
Comment 2 Markus Keller CLA 2005-06-14 03:52:32 EDT
IMO, it should not use any prefix/suffix at all, unless core adds special
prefix/suffix for static final constants. Depends on bug 85946.
Comment 3 Markus Keller CLA 2007-03-29 06:11:18 EDT
Works fine in I20070327-0800 (currently uses no prefix/suffix).